Snapmaker 2.0 and Vectric VCarve Desktop - a good match?

Just a quick note on my workflow with vCarve/Snapmaker. I go straight from the vCarve .cnc output produced by the post processor to a USB key in the Snapmaker.

There’s no value add for adding Luban into the loop here as far as I can tell. Just load up the file directly from a USB key, set your home and let it run.


Honestly? I just send it directly from Aspire to my Snapmaker. For whatever reason when you import gcode from Aspire into Luban it screws up, at least in my experience.

I think it might be because Vectric is for professional use and not intended for any single machine over another. Which makes me think Vectric generates better gcode that can’t be read right by Luban. The machine has no problem with the gcode from Aspire, if anything it really brings out the true potential of the Snapmaker.

Also, I keep saying Aspire. Vcarve, Cut3D, etc… are all just segments taken from Aspire to keep things simple for those that only want the corresponding capability. Aspire is everything. Just don’t want to be causing confusion by saying Aspire.

Yup - the Vectric family is all about a single core engine that is sliced into feature sets by market focus (and price segment). But once you’re in that ecosystem, Luban offers absolutely no additional value. My Snapmaker is in the basement so it’s not convenient to send stuff directly (hence the USB key route), but it’s all direct from the gcode generated from the Vectric software and works (almost) all of the time.

Curiously the only thing that I ever had an issue with was the most simple job where I was just leveling a round cutting board so I ran a circle pocket cut with a large (6mm) bit which translated to a single cut on the snapmaker. Doing the same operation with a square pocket work fine. :man_shrugging:

That said, all of the complicated cuts and engraving all worked beautifully.

1 Like

How do you send file from Vecteic direct to SnapMaker?
I am testing with trial version and the option to output direct to machine is greyed out even with demo files.
Hwo do I enable this or is the full version required?

I’ve never gotten that to work. I use the old school USB method for sending vCarve output to the Snapmaker


Is everyone using this post processor in VCarve?