Small issues with first prints

Wirth a layer height of 0.16 and 40mms ist nice.

Thanks for the video. When I do exactly what you did, I can just use the weight of my hand, I don’t have to apply any extra force, maybe 5lbs applied maximum.

I did have a partial clog once and I had to do exactly what you’re doing, push down with force.

Try doing a cold pull:

Might not help, but can’t hurt and only takes a minute.

I just changed the whole hotend and I’ll give it a new try :slight_smile:

@Slynold I think, this is a combination of issues.

With a layer height of 0.08mm i would suggest to print on the bottom temperature the filament is able to.
The second point about temperature with superfine prints, did you assemble thermalpaste to your thermistor?- This would help to get more consistent outputs.

If you print such low layer heights, you need to calibrate your heated bed very well, best as possible. Because if you dive through your previous layer (even minimal) you will get this peaks on the outside.

I would suggest to print the first layer with 0,2mm, after that 0.08mm or how you like.

I also heard about the reputation of Cura. It’s very unique with it’s rich features and quality performance. Thanks for the video.

Hey @xchrisd. Thanks for your input.
I ordered thermalpaste a few minutes ago from amazon after looking at the hotend i just pulled out of the extruder. I’ts a nice construction but everything is a bit loose in it. I’m curious how it’ll behave with the paste.
I use five points autocalibration - i know this isnt the best i could do but i thought that at least the middle will be level after fixing the z-offset.

Its hard to calibrate the first layer very well, even with z-offset.

A visual guide showing the different effects of z-axis calibration.

A visual guide showing the different effects of z-axis calibration. Source: Prusa Research

So here is my banchy with the new nozzle.
It seems that the artifacts are a bit smaller.

I can see the nozzle on the chimney.

The bottom / first layer looks okay, or am I wrong?

The bottom warped in a tiny elephant foot.

The first layer looks good. I think there’s a small bit of overextrusion causing the elephants foot as well as the mark on the top of the chimney in the last pic.

I think taking these pieces of info together: a) .16 / 40mm/s layer height has no artifacts, b) new nozzle didn’t fix the artifacts, c) last print settings did have the artifacts: I think it’s something with the settings, maybe that layer height just needs to be avoided? Really wish I could watch it print, hard to diagnose images just from a picture.

When it leaves the artifacts during printing can you tell what’s causing it? Is it when the nozzle starts or stops the perimeter? During the perimeter? Is it just a small amount of overextrusion that’s being pushed out the side and curling? Maybe retry, but drop your flow multiplier 1%?

After switching nozzle I havent recalibrated the extruder steps. I’ll do that today or tomorrow.
When I’m home I’ll share my gcode, so you could try it if you want to.

I watched it for a while. You can see the nozzle creating these artifacts. I wish I had a microscope for detail analysis. I sat there with a beer, magnifying glass, and a laptop watching the printer and the simulation at the same time.

Let me know if your esteps has changed - I’d wager it shouldn’t have changed since it’s mostly measuring the stepper motor. A slight change in backpressure from the nozzle change could have an effect, but it should be very small.

I can’t remember if you’ve set the filament diameter with a micrometer - that could have an effect also.

This is my gcode of barnacle benchy. (2.2 MB)

If someone prints this and has the same artifacts on it is definetly a configuration issue.

Haven’t got time to check my e-steps. I hope i could do it after work

So after my first extruder calibration my e steps calculated to 246.75.
I rechecked that now and it is 254.38.

I cannot explain that. I think I need a better way to measure my filament.

I’ll do it again, cold. :man_shrugging:

i made some changes. Replacing my nozzle, thermal pase on the thermistor, and re calibrated the extruder e-steps.

My first try, weeks ago led to a value of E246.75. My second approch, days ago led to a value of E254.38 .

This was strange, so i tried it with a cold extruder. I prepared a bit of filament. Taped it on a desk, marked some measure points, and after that used this piece to calibrate it.

Also I found a nice web formular to calculate the e-steps.

After that I measured my filament at 10 different postitions and calculated the overall diameter.

I’ll try my benchy again later.

So, sadly my new result isn’t better.
The actual gcode is this: (2.2 MB)

It would be nice if someone could try it out!

Well, one issue I see in here is there’s a some extra stuff.

  • The start of the file disables linear advance, are you doing that intentionally? You may get better performance by calibrating linear advance rather than turning it off
  • The gcode is constantly changing the acceleration of the printer, using a deprecated field that is not supported (M204 S). Can you remove whatever is generating that?

I can’t run that code, but I could give you a benchy I sliced. Good luck, not sure if it’ll run well for you.
A350 3DBenchy S3D (1.1 MB)

No this was not my intention. It seems that the cura plugin for llinear advance turns it of when untouched.
I wanted it to be at default. I’ll check that again.

Cura uses by default dynamic speeds for each part (walls, travel, infill and so on). I don’t know why its using a deprecated field. Maybe it has to do with the g code flavor? I chose marlin because it’s suggested by snapmaker. This is bad :frowning:

It looks like this is one argument for S3D.

Yea I’m not sure, the Marlin docs say it’s deprecated too, maybe that plugin is just out of date??

Legacy M204 S<accel> is deprecated. Use separate paremeters M204 P<accel> T<accel> instead.

The files I’ve sliced with Cura don’t have any M204 commands in it. I’m still learning Cura - is the dynamic speeds something that’s on by default or is it something I would’ve had to turn on manually?

This is what i call dynamic speed settings.

Now i’ll make different slice approaches and look for the M204 S.

Yesterday a friend printed my gcode with his Ender 3.
There are other ones, but not the same artifacts (barnacles). This is strange.