Set safe work origin after firmware update (if you don't want your Snapmaker destroyed, that is)

Why doesn’t Snapmaker warn the user to set the work origin safely after a firmware update? I just updated to firmware 1.14.1 and when going to work origin my laser head plunged right into the bed. It looks fine for now and I hope no issues come up in the coming days. Did I miss information anywhere? I did not see any warnings for this in the manuals or update notifications.


Sorry, maybe a dump question: What does ‘Set safe work origin’ mean?

This situation can probably happen when you physically have for example A250 and your settings are for A350 etc. Maybe that was the reason in this case?

Not sure why but this also happened to me on the initial start of the calibration test cut

As a matter of course I set the origin manually every time I switch on when using CNC.

1 Like

Along these same lines, can someone instruct me on, or if you can set the Home location on the printer?
The preset moves the printing bed forward each time, and that is where I have my laptop setup, not to mention it almost knocking over my beer the other day! :sunglasses:


“Home” is the name for where the limit switch is inside each linear module. When the machine starts up it doesn’t know where anything is in space and has to move each axis until it bumps a switch, letting the controller know it’s now in the “home” location. More specifically, the linear modules operate as open-loop control with no position feedback - there’s no encoders reporting the linear module positions back to the controller; only the singular switch at the end of the travel.

The only way to do such a thing would be to turn your Y axis modules around to face the other way or otherwise move the location of the switch. I think I’ve heard of someone doing this, but overall I think it’s more complicated than it’s worth as it will mess up some of the touchscreen functions like automatic bed calibration.

Edit: another workaround could be leave the machine on and put it into what i’ll call ‘power saving mode’ - it doesn’t draw much power sitting there doing nothing if you disable the stepper motors. Rather than turning if off you could do that, and then when you want to use it again it won’t need to home again. “power saving mode” in this case are the gcode commands M18 to turn off the motors and M17 to turn them on again

There’s a caveat with this. If anything gets bumped or moves without the holding force of the steppers on the lead screws, the machine will lose track of its current position and need to be rehomed. Plan on the z-axis lead screws moving, for example, because of gravity on the x-axis module. Homing the machine will reestablish its tracking of position.

We had this conversation in Dec '20 exactly a year ago :slight_smile: Yes, that is the safest behavior, but spilled beer is also disastrous, it’s a trade off in this case

1 Like

I have had the same issue. Laser crashed into left bottom corner after the firmware update.
My hope is that nothing was damaged because of that. :frowning:

Wow, I thought I was the only one to achieve such a feat. I attributed it to the fact, that I was lazy and mounted the laser bed modules on top of the printing bed. This also happened after the latest firmware update.
My theory is however, that somehow the work origin of the laser module gets set to the one of the printing module (0,0,0). Thus, if you havent set your new work origin or completed calibration of the module after firmware update, it might crash into whatever you have mounted beneath. :thinking:

I have to agree with OP, the firmware should set the work origin to the home position (at least for the z-axis) as default after each fw update / reconnect of the module.

Anything’s possible with this machine, when it comes to XYZ state invalidation.

I had the 3DP mesh lower itself from +6.xx to +0.05x roughly. had i printed the head would have pressed its way to -5 mm under my build surface.