Problems with setting workorigin over usb connection

I am having problems trying to set the work origin for the laser using the direct usb connection. Using the SET WORK ORIGIN option to 0,0 from the LUBAN workspace menu, results in the laser head being lowered to bed level, but positioned to the top left corner, just off of the bed area. There does not appear to be an obvious solution here.

I am using the position option boxes on the LUBAN menu (bottom left side). But regardless of the position option selected, it does exactly the same thing.

If I start etching a graphic with the laser, it does not move from this top left position and starts the laser etching right where it is.

When I set the work origin, home and the go to the work origin from the control panel on the snapmaker, it does it perfectly.

This confuses a lot of people. The problem is that the work origin and how it’s displayed differs depending on how whether you’re using the usb or running from SM. (and is different with the different toolheads) It’s stupid and been complained about but SM doesn’t think it’s an issue.