Problems with laser engraving


#1

Hey there,
i really enjoy using snapmaker. it is much fun to test this awesome product.
But i have some problems with the laser module.
i testet it on wood, and it went without any major problems.
No i tried it agein, and i didnt get it done.
I have a picture in

2118_Oma.nc (9.2 MB)

i tried it with different algorithms, and with different focus which i adjusted directly at the module.
the secong thing is, i dont see the laser configuration in the snapmakerjs software either,
allthough i already installed the new driver for the printer.
Does someone have information for me to do a workaround?
Merry Christmas everybody
thx for your help.
Greetz
Florian


#2

Hi Florian,

I just tested the laser module yesterday for the first time. At first I did not saw the laser configuration in the snapmakerjs software either. Then, I realized that the connection did not worked properly. I am using a Mac. After reading the readme file that came with with the driver and reinstalling the driver it connected correctly and I saw the laser config. I have to select the port: /dev/tty.wchusbserial1410 for the connection to work.

That’s my daughter who operated the machine. She first scribed a mandala in B/W at 100% power on baltic birch and the results was perfect on first try. She then try a photo like you did but the results were not good. Your engraving was much better. I guess there’s gonna be a learning curve there.

Happy holidays!

Pierre


#3

Hi,

Checkout Laser widget(You need to set up laser module and connect to it first) and Laser Tab.

@pierre_l Try adjusting laser power and moving Z-axis to focus laser.

Checkout below resources

https://manual.snapmaker.com/laser_engraving/set_the_work_origin_and_adjust_the_focal_length_us.html


#4

Thx for your answers.
After updating snapmakerjs to 2.2.2 the laser widget appears now.
I tried it again to engrave, but i think my laser module is defect. i dont know how to test it.
But in this video (https://www.youtube.com/watch?v=aQ2m4sNiFB8&feature=youtu.be) you can see, that my laser doesnt even has the power to cut through paper.
Maybe my workflow is wrong, but i dont know, what to change now.
Please help.


#5


here are photographies from my “focused” laser point. i think there might be a problem with the focus, but it wont get better, when i adjust the z-Axes, i tried also to rotate the focus on the laser module. Maybe somebody can help me.
System is up to date: Firmware, Snapmakerjs 2.2.2, PC with actual windows 10 OS
tried with another pc too. :frowning:
Greetz
Florian Nigl


#6

Florian,

When you click on focus, the laser is turned-on at low power. It won’t cut paper at that power level.

Did you tried to adjust the focussing ring on the head. With the focussing ring on the head fully tighten, my focus point is about 34 mm away from the end of the laser focussing ring.

I suggest you try it anyways to scribe a simple B/W exemple on wood or mdf so you could play with the power. Here picture of my laser in focus and engraving results.

I hope your laser is not defective.

Pierre


#7

Hi fnigl,
Today I managed to acquire the SnapmakerJS software and set up laser mode and got great
test results, at first. However things started developing just like your example. While it tracks the
image there is no power to mark anything, While I’ve tried all I can to get the laser to ‘spark’ I’m
rapidly coming to the conclusion that the laser is faulty.!
As they say the software is ‘Beta’ (Better than nothing, but a hell of a lot better than several other programs
I tried which overall failed to deliver probably because they just did not have the ability/software installed to drive the Snapmaker) I am also observing that things seem to be switching in the Consul Widget between CNC & Laser like it can’t make it’s mind up exactly what it is supposed to be doing which looks to me like a ‘bug’ and is effecting laser engraving.
I’ll persevere a while longer as I have not given up the idea it is ‘operator error’!


#8

Thanks for your help.
I tried a few constellations now, even a black and white example. But my laser doesnt even has the power to burn into paper. So i’m really sure, that the laser is defectly.
i hope there is the opportunity for a warranty exchange. Anyone knows which way to go for warranty?
Greets
Florian Nigl


#9

Hi fnigl,
With some more hours on the Snapmaker and Laser engraving to me it is looking more like the issue is software
rather than the Laser as it is still working but just seems not to be coming up to the designated power. If the laser was faulty one would expect to get nothing but we are getting a ghost image. As the laser is a diode device like all diode devices I have used over many years they either work 100% or they don’t. (0%)… nothing in between
The software is at this stage ‘flaky’ and it has a long way to go in that some things I would expect to find are just not there or are hard to find for ease of use. One thing Snapmaker have missed is a operaters manual on just how to use the software. For instance I can’t figure out what the ‘F’ or the ‘Focus’ is or what it does and I have yet to to be able to get a imported ‘G code’ file model into the correct position on the platform for CNC engraving. The model just sits way out north east and no way to simply move it to the origin position where it needs to be. I have also yet to find out how to control the
CNC motor speed and not go for a Perspective view as this will lock the display up and one has to restart the program.

However with these starting .‘glitches’ I have found out that this machine is a top flight product and capable of better quality of 3D printing than I have been used to and even with the starting ‘glitches’ I can see it can produce excellent laser engravings and fine high quality CNC carving so early days. A bit of a shame the software is not as advanced as the machine mechanics and engineering but guess that will come with time… well I hope so.else I will have to write my own software.
It;s a brilliant machine… almost too good to take out of the box. [G]
DVW.


#10

i agree with you. the quality of the printed 3D Models is awesome, exactly within 1/100 mm, thats really top.
But i dont think its a software issue in the laser.
I engraved a photo, wihtout problems, the second photo i started to engrave went until maybe 1/4 of the photo perfectly, but than it went further without the power… a few tries later it was just possible to engrave with the examples you see in my earlier posts. i cant figure out, why it should be a software problem started within one engraving session…
hope we’ll find a solution
Florian


#11

Hi Snapmaker users,
Happy New Year.
I’m still having problems with the Laser not coming up to power and producing the
perfect result it did when first used sadly.
However I have found this way of getting the focus spot on consistently:
The distance from the laser lens mount I found to be 40mm for a good focus for my laser so
make a focus gauge out or a piece of photopaer or a piece of fine spring shim brass, (paper has no spring).
and cut it to your work/laser head distance. eg in my case 40mm.
Lower the laser head Z axis (- ) down till the gauge ‘bends/jams’ a little between the job surface and
the laser lens mount and then on fine Z control (+) activate till the gauge falls away.
This should save trying to find the microscopic laser ‘dot’ which at times is virtually impossible to see
properly.
Happy laser focusing.
DVW


#12

Hey there,
i tried all solution suggestions you told me… but nothing worked…
Please help me, to get this laser to work
Here are the videos:



Focus is at its best,
Laser Power set to 100%,
work speed reduced,
i’m down with my nerves…

Thanks for your help
Florian


#13

Hi Florian,

Apologies for the late reply. Please provide the following information to help us troubleshoot:

  1. Do you use the fixtures to immobilize the material? If you only fix one corner of the material, it may not be flat enough for the laser to stay focused.
  2. Do you remember which of the following was engraved first? The right one or the left one?
    image

Look forward to your reply. Thank you!

Best regards,
Rainie


#14

Hello Rainie,
The right picture was engraved first, picture on left side was engraved Second.
I use fixture, so that the material cant move and is flat.
Isnt is possible to warranty exchange the module, to Check if this is the problem?
Florian


#15

Hi,

How does it turn out after you fix all the 4 corners of the material? Could you please use this G-code to test if the laser module is defected? Please use 100% power and B&W mode.
laser test.nc (282.5 KB)

Please send photos of the results to us. Once the problem is verified, we will send you a new Laser Engraving Module to replace the defected one.

Look forward to your reply. Thank you!

Best regards,
Rainie


#16

Hello Rainie,
i took a few videos and a picture of the "product"




Unfortunatly there is no “product” at all
Florian


#17

Hi Florian,

I would like to have a videocall with you to better identify this problem. Could you please tell me what is a proper time for you? I am available from 9:30 am to 8:00 pm CST, Monday to Saturday.

Look forward to your reply. Thank you!

Best regards,
Rainie


#18

i’m waiting for you to call, didnt you get my email?

Greets
Florian


#19

Hi,

No. I don’t see your email in the inbox of support@snapmaker.com.
Could you please send it again?

Best regards,
Rainie


#20

Hi Rainie,
I sent you a email today afternoon.
I would be pleased if we could solve this problem early. I want to start projects with my pupils in near future.
Hope we’ll find a solution for my problem. So i think we should take this video call as soon as possible.
Greets
Florian