Problem solved (Thanks Wayne)

After an answer today; to my crie de coeur by Wayne, I was able to download and read what I needed to see. I have attached a picture showing about 25% of my first handmade toy. Should be obvious what they are at any rate.

I used 40mm cubes of pine (nice endgrain) and I created the letters in Affinity Designer and exported them as .svg files. Herein was my first issue. The .svg files were not readable by Snapmaker JS or Luban. The rationale behind using vector files is so that one can make the file any size because it is resolution independent. I was also having difficulty finding the actual workspace in Luban and Wayne helped me with that.

After discovering that the integrity of the .svg files was in doubt as far Snapmaker software was concerned, I made the .svg files fit into a 39mm square and converted them to .jpg files. My thinking was that if I did not have to resize the files too much, then they would stay clean and have smooth outlines. The advantage to me to discover that I could use .jpg files is that I have a huge collection of fonts in my Affinity software, which can be used for vector, bitmap and publishing activities.

Luban was found to open correctly after I had followed Wayne’s advice. I opened each file as a B&W image and sized the image to 39mm square. The line direction was set at horizontal and I changed the density setting to 10. The jog speed was left at 3000 mm/min and I set the work speed to 800 mm/min. the power was set to 50% and fixed. (I am using the 1600mW laser module)

The g-code files were generated and then saved to file. All of the files were saved to a USB stick and although I work with MacOs, the stick was formatted to DOS-FAT32. I ran all of the files from the stick and they required anything from 3 minutes to 6 minutes depending on the complexity of the letter shape.

The results should speak for themselves. There is no discernible edge burn or smoke staining and these look like a high quality item. Thank you Snapmaker team and all of the people on the forum who have helped and guided me. Thank you all. :blush:

3 Likes

You’re welcome, Jepho. Enjoy your machine~ :smile:

Whatever laser power I use, mine all come out the same. I wonder if it’s fixed in the G-code file that Luban sent to the device/machine – and I worked from there, the Mac OS software being so unreliable. Even if I set the dial to 20%, makes no difference, it reverts to 73% as soon as it starts working.

I am not sure but my method was to uncheck the fixed power box in Luba and then adjust the laser power and then check fixed again. I think that is how I got my setting to stay where I wanted it.

Then you are correct, Luban encodes the setting in the g-code. I then save to file and insert the stick. I believe it works ok with the USB A-B connection directly from the computer but I found testing the laptop on top of the enclosure not to be ideal.

I still think the process is uncheck the power setting fix, change the setting then fix again to keep. I may well be wrong and if so, I am sure someone will be along soon to point out my faults and errors in processing files.

Kind regards,
Jeff

Should be like that, Jeff. But then why does the handset on the machine take us to a page where the user can set the laser power – if we disconnect from the Mac, after sending the G-Code file to the machine? Changing the power there made no difference for me. That page should not appear as part of the sequence, if it’s already baked into G-Code. That is the kind of basic redundancy that we, the users, are having to navigate on this software.

Don’t talk to me about always having to set the density, and other parameters, ever single time we load a new image. That’s just stupid. If I’m doing a job, I’m probably doing similar, even repetitive work, which needs the same settings every time. Density, especially.

Also, I discovered today that flipping the image in Editor, or rotating the image 180 degrees, has no effect, though it seems to be working. When I go to Process and load the G-Code to the workspace, it hasn’t inverted at all.

Here’s the thing I don’t understand: the company bragged bout the millions of bucks from Kickstarter – greatest of all time, etc. So, what happened to all that cash, and why don’t we see it reflected in the software? Look at the workspace: when we zoom out we can’t even make out the measurements, can’t pan at all … that is a really bad return on our investment.

All I can think is that they are out to make as much money as possible, and reduce every marginal [in their eyes, but not mine] expense. No more Mr. Nice Guy.

I think I misled you unintentionally. Under the thread entitled, “Luban next version suggestions” I mention setting persistence issues. JKC20 responded with a message about saving your custom profile and then getting your settings back after reloading it. I did not know that but in any event, I have had the devil’s own job in trying to keep settings constant. If JKC20 is right, does that mean my batch settings for the work I am currently trying to finish will be saved along with my profile?

Some things are less than sensible to my mind… why do I have to keep changing the process section to editor when first opening Luban? Luban should know that is has not been used (as clicking on the application should tell it that is has not been open) and the user is likely to want to open a file on first use. A case of setting persistence when it really is not required.

I have not managed anything complex like flipping images because I only want to learn what I can understand. Luban does not feel like it knows about what I am likely to want even when I have just carried out a series of operations and want to continue doing so for the next 200 files.

I gave up using the computer and put all my files on a USB stick.I run them through the free to use CAMotics (https://camotics.org/) to see if they are going to work how I think I have asked them to work. If they run correctly, then they get loaded onto the stick and I don’t try and change anything on the file after I consider it to be cooked.

My issue discovery is today I wanted to carve a 40 x 40 x 10 mm square. CAMotics shows me that the file is good and that it will be carved by the CNC machine in the manner I expect… Except it wont. CAMotics has a speed setting that lets you view a complex file in speeded up time rather than real time. I did that and did not think any more of it.

The first cut of the CNC endmill was great (.5mm deep and done in a second) and I was looking forward to finishing cutting my jig and finishing the alphabet blocks I am making. The second cut was at the same depth but the endmill had taken a (say…) 0.1mm bite out of the remaining material. It traversed it at the same speed as the first cut but took off this tiny amount. I would have expected it to move the cut half the diameter of the cutting bit of 3mm so a 1.5mm movement. So the whole job will take around 9 hours! Instead of what I had expected to be a 30 minute job at most. I have no idea what they call that second pass of the endmill nor how to control its bite or speed of working.

Oh, one other issue that made me scream in pain… My wife did something while my piece was cutting. We had a power outage and then I restarted the machine after a couple of minutes. When the handset informs me on first jogging the cutter to the start point, that it has saved that location, I expect that to be persistent. It is not! Once power was restored, I started up the machine and immediately cut a swathe through a point that was nowhere near my intended milling path. Ruined! One piece of work that represent numerous hours of set up and work time.

Oh well… onwards. I have attached an image that shows you how I skirted the 90mm limit for CNC carving. I am carving the jig in situ and it will be left on the plate until all of the blocks are etched. The modification is to the cap headed screws. These are A2 stainless steel with a full sized 3mm hex socket.

Business! All businesses must make money by law… the reason as I understand it is this: If a business is not actually making a profit, it is trading below the line. That is to say trading while technically not making sufficient money to cover its normal business expenses. Fraud in other words. I am sure a lawyer could explain it far better than I could.

I don’t worry unduly. Money makes the world go around and the piper has to be paid. The rate is neither here nor there. Either I want the product and am prepared for the expense or I don’t. There is no middle ground like I want the product but only think i should pay x. Have a good day.

We have heard your feedback and are thinking about adding the feature to save the settings for laser engraving. Now that at least a couple of people have requested this, it is possible we are going to add this feature sooner. Recently we just added the feature to save custom profiles for 3D printing. And you can pan in Workspace by holding Ctrl while moving the cursor. One thing I know is that we do need to make a software guide… I have forwarded this suggestion to our team.

2 Likes