PNG, JPG, BMP etc always load at width 40mm

As the title suggests, Im having trouble with loading these kind of images into Luban, it happens all the time in CnC mode both 3 and 4 axis, but not often in Laser mode.

Everything ive tried hasnt had any effect at all. Changing the source image size, resolution, file format and probably a few dozen other things ive tried and cant recall. No matter what i do, when i bring the image into Luban its always at 40mm wide. Height seems to be correct in relation to the width but the width will always be that durned 40mm.

When i transform those images to bring them to the correct size, i end up with blurry edges where in my original I had sharp ones. Going from black to white (at least in my mind) with a clean edge should give a relatively vertical cut, but after resizing the image in luban, those blurred edges mean im getting a bevel all the time.

I dont know if im missing something obvious, a setting or check box somewhere. Or if i need to be creating the source images at a specific resolution or something. Anyone with any insights into this Id be grateful for your thoughts on it. Its driving me loopy…

Thanks!

Urk dammit : PS : Using Luban 4.0.1

The thing you have to remember about Luban is that it’s riddled with bugs. This sounds like another one.

Haven’t had that problem.
Is the ‘job setup’ set to the size of your SM? It didn’t get accidentally set to 40mm?

Share your files and we can see if we get the same result.

-S

If its a bug I can accept that, I read somewhere that the cnc features still have that new software smell.

I’m trying to avoid Fusion 360, once i install that I’m going to start feeling compelled to pay that insane amount per month just to get access to the rotary module. Though if this is a bug in Luban, I imagine I’ll have to install it and try and exercise enough willpower to hold out.

Ok try FreeCAD then. If you do this branch fixes a few things, including the topological naming problem: GitHub - realthunder/FreeCAD

@ sdj544
The job set up is to the size of the chunk of wood im using. 300mm x 60mm. Its an odd size, Im using up cut off pieces ive had laying around.

That is one of the PNGs im using, (Hope that file upload worked)

Edit : Thats not ‘exactly’ the same file, the forums processed it so its down in size. I cant upload the save file, doesnt like that type of thing apparently. Errr… If i can figure out how to attach a file I’ll do it that way too.

Edit 2 : This is what happens in steps, screenshots ho!




Step 1 - Import
Step 2 - Resize with in app transform, you can see a helluva blur form on the edges there, that goes away (mostly) when you click the boundary box, guess it just doesnt directly update the image if you use the numbers to scale it rather than the drag handles.
Step 3 - After the image gets all nicely resized and redrawn, you can just make out the blur that still remains on the edges
Step 4 - Insets showing a close up of the edges and the same spot on the original source file.

I’ll have a deeper look at that one. I remember seeing it mentioned somewhere though isnt their support for the rotary tools or 4th Axis stuff still in development?

It does look like I might just have to join the ranks of the sane and use some different software though. Id pay something for fusion 360, just not $60 USD for access to one bloody feature that shouldnt have been cut in the first place.

Thanksya :wink:

More than $60 LOL. Rotary 4th axis requires the machining extension: Machining Extension | Fusion 360 | Autodesk. Another $200/mo on top of the $60.

I thought FreeCAD had rotary…maybe it’s still experimental.
https://forum.freecadweb.org/viewtopic.php?f=15&t=36018

Sweet mercy, 3 grand a year for those who just like to tinker… oooookay… Now i might just use the free version just to spite them. Either way I’ll install FreeCAD and see if my old and less elastic brain can handle learning it :slight_smile:

Update : Starting to wonder if it might be something other than the images getting jiggered with on rescaling. Imported a simple STL, just a straight extrusion of a simple logo. When run though Luban and the workpath created, the path still shows that roughly 45 degree bevel thing even though it was set up using a straight flat end mill bit. Maybe its something in the way Luban calculates workpaths for anything set to ‘Carve’ because it will do straight sides perfectly if the method is set to the Vector one.

Stumped right now to be honest, given the simplicity of the vector shaps in the CNC section, its impossible to recreate what im trying to do with just Luban alone. Im neck deep in checking out FreeCAD and heavens help me, Fusion 360 as well and its a helluva steep learning curve.

So if anything occurs to anyone about how i might fix this for doing stuff purely with Luban, please let me know, Fusion and FreeCAD are seriously overpowered for what im trying to do to be honest. If i have to use them I will do, once i figure out how to actually do something. :wink: