Old Luban projects incompatible

Hello there, roughly a year ago (don’t know my old Luban version, unfortunately) I stored some of my laser projects in a .snaplzr file but the most recent version of Luban can do nothing with it - it just opens up a clean workspace.

Is there any way to open old projects with the most recent version? Is it the indented way? I think backwards compatibility is a definite MUST in the maker scene to be able to replicate your old parts when e.g. replacing them.

Any help would be really appreciated.

Best regards

Erik Schnell

I have the same issue:
File > Open > [select a .snaplzr file]
…blank workspace

Older versions of Luban can be downloaded from the forum. There’s even a link to SnapmakerJS.

Hopefully an older version will let you export your work, or save in a format that the newer version supports. I would install the old version on a different computer, or in a VM or container, so that I could experiment more easily.

Were you able to open it before and have it bring up your old project in a usable state?
I never got it to work when I tried it (probably 3.12 was first time I tried it.)

If you’re on a mac you can have any versions installed simultaneously. Just rename with version number at end to keep straight. Some versions you can open at the same time. Some you have to close one. I have 3.8, 3.12 and 4. I generally use 3.12. Didn’t like interface changes to 3.13 and 4.


I was able to re-open them for simple tweaks and the engraving process was fine. I will try opening a file with an old version and let you know whether it worked.

Thanks for your reply! I will check out an old version and see whether I can get it working.

So, it actually worked with older versions (tried multiple 3.*). Unfortunately, laser parameters are gone, whatever the version. Maybe the old version was unable to store them. I hope that Luban is able to do so in the meantime.