Nozzle collides with model halfway through print

I recently got my Snapmaker 2.0 A350 (Woohoo!!)

After a 3Dbenchy and calibration cube that printed well, and a Snapmaker Vase that went fine until the half way and then had a nozzle clog so it printed into the air, I started attempting to print a goose, found here (specifically the single.stl file).

I created the goose with Luban ( and an earlier version for the first tries) on MacOS 10.15.5.

During 3 attempts to print the goose it failed in the same way that I believe is a gcode issue (or possibly firmware, but not reproduced on the vase that got about twice as high). During the print at 53% complete (the third time, which had ever so slightly different gcode, might have failed as early as 49%) I heard a knocking sound which I assume to be the extruder contacting the back of the print and sending it flying. In the attached photo there appears to be a dent/melted spot from the nozzle in roughly the same position on each goose.

I’m unable to attach logs since I’m new to the forum, but if it would help debug I can attach them after awhile. In the two versions of the gcode the main difference I can see is the min_z and max_z goes from -/+67.7 in one file vs 0 to 135.4 in the other. No changes after line 40.

My Snapmaker is on firmware version, touch: 1.10.0, and controller 3.1.8.

Any ideas how to debug or prevent this sort of failure? (I guess my next step is to grep through the gcode and see if the Z position seems to go in the wrong direction.)

I checked the Z values through the file (grep and sort) and noticed that none seem to go in a decreasing order.

Was the model still well on the printsheet at the abort of the print job?
I guess this could be adhesion problems, slowly loose the contact to the build plate causing a crash with the head.

Thanks for the comment, I believe the model was still well adhered. Usually when I heard the snapping noise one of the feet remained attached to the platform while the body snapped off and went flying.

My z-index is set to +0.1mm which seems to stick well but still be removable (when I did the first print at 0.0 it took me 30 minutes to get all the bits of the skirt off)

Possibly the legs on this model are two flimsy so it wobbles?

Do you use any supports?

No supports. When I try to enable in the app the checkbox doesn’t seem to work last I tried. I will try that again.

With supports it finally worked!

To turn on supports I had to change the profile from one of the built in to a custom/copy and then I could modify/enable. (Obvious enough in hindsight.)

In some intervening failures (including one with gcode generated from Cura) I noticed that the feet were solidly stuck to the platform so it wasn’t detaching.

I’d be curious if people have explanations to why it’s happening and how to avoid, but I hope it’s related to the model. My best guess is that the tail was both steep and thin, and as it was cooling it warped, which caused the contact to happen.

Fortunately, removing the supports was much easier than I was expecting.