Need Lightburn to activate the Air Purifier on RAY-40 (doesn't seem to be "M1011 F3")

I see the articles written for the 10W for Snapmaker 2.0/Artisan guiding to use “M1011 F3” However this does not seem to be correct for the RAY controller.

Luban turns it on, (plus you can use the “control” function to manually set it) but Lightburn does not (yet) and incredibly inconveniently, you have to power cycle the RAY when switching from LUBAN to LightBurn due to a control setup difference, so even if I used LUBAN to turn it on, it shuts off when I cycle power to connect LightBurn.

I don’t see where it is being turned on in Luban, but just in case, I saved G-Code from the sample protractor/ruler project provided in Luban for the RAY.

As a new forum member it is not letting me upload the g-code file but below is how it starts – in case someone sees the needed action code…

LightBurn is controlling the enclosure fan just fine, but I have to say, without this functionality, I don’t find the RAY to be fully functional in LightBurn because I can’t extract the smoke other than with the little enclosure fan.

;Header Start
;header_type: laser
;tool_head: 40W Laser Module
;machine: Ray
;gcode_flavor: grbl
;renderMethod: line
;max_power: 600
;file_total_lines: 2624
;estimated_time(s): 272.515
;is_rotate: false
;diameter: 0
;max_x(mm): 114
;max_y(mm): 140.33100000000002
;max_z(mm): 0
;max_b(mm): 0
;min_x(mm): 0
;min_y(mm): 0
;min_b(mm): 0
;min_z(mm): 0
;work_speed(mm/minute): 2400
;jog_speed(mm/minute): 6000
;power(%): 60
;work_size_x: 600
;work_size_y: 400
;origin: bottom-left
;Header End
;Snapmaker Luban 4.10.1
;Sun Nov 26 2023 21:27:28
; Laser multi-pass, pass 1 with Z = 0
; G-code for laser engraving
; Generated by Snapmaker Luban
; G-code START <<<
M2000 W1P100
M2000 W2P100
M4 S0
M2000 L23P0
G0 F6000
G1 F2400
G0 X97.783Y124.305
G1 X98.388Y126.73S600
G1 X95.962Y127.335
G0 X83.366Y89.172
G1 X76.018Y88.4S600
G0 X79.976Y78.385

The M1011 F3 was used on the 2.0, they decided to change a lot of gcode for the Artisan and Ray for some reason and it’s been a real struggle to get any information out of them. Even on simple lines like this, most everything seems to be rolling under the M2000 command.

Try this in your header (this is from the Artisan forum, but that’s closer to the Ray than the 2.0);

M2000 W42 P1
M2000 W40 P3

@Savoie Managed to get the lines, though no real explanation of what they do.

1 Like

@Skreelink : Bless you and your home and all of your extended family!

I tried above and while it is hard to to confirm just by sound which speed it is coming on at but here is what I found on the RAY:

M2000 W42 P1 – THIS DOES turn on the filter - not sure speed!
M2000 W40 P3 - I cannot confirm that this did anything - no speed change
M2000 W42 P0 - I tried this on a wild hare and THIS DOES filter off!
M2000 W42 P3 - I tried this (along with W40) to see if I could confirm P3 with speed change but no dice.

I will need to record sound from Luban on speed 3 and from Lightburn with above command with my phone to try to confirm the speed I’m getting, but either way it’s no longer a brick! Thanks!!!

Maybe W42 turns it on/off (P1 on, P0 off) and W40 changes the speed? Try W40 P0 through P3.

@Skreelink You are right again - it’s subtle and odd but I think the W42 On/off seems to turn it back on whatever last setting was. W40 [P0 - P3] DOES control the speed and if you turn it to P1, then turn off with W42 P0, the next time I turn it on it resumes at P1 instead of the default which seems to be 3 after a power cycle.

Confirmed as soon as I tried W40 P2:
It had started on 3, and I could hear it drop to 2.

Thanks - now I don’t need to play inspector with recordings and comparing pitch :slight_smile:

Glad my hunch was right. :slight_smile: Enjoy.

1 Like

Trying to get things settled and happy in 2D before opening the next box: rotary.
I do hope that works well in LightBurn without such quirks.

I have nothing personal against Luban, but when I open a multi-layer SVG and it not only comes in as one layer, but also does not have an “un-group” function, and my work-around is to use light-burn to save each layer to a separate file for Luban, I do begin to wonder “why bother”.

It’s a bit quirky as well for rotary, however, I think that should be dealt with in Lightburn 1.15. I did have an old guide for using the 2.0 rotary with Lightburn.