Misprint Realignment


#1

This is the third time I have had this problem. When trying to print a large number of models, the printer often re-aligns it’s x/y “home”, and starts printing subsequent layers at different points along the build plate. I have had this happen on multiple models, and it always seems when I am putting many objects into the same slice file.


I have had the Snapmaker for many months without a problem like this. Could this be a result of a firmware update? I recently updated to the 2.6 version of the firmware, and it’s around this time when the problems arose.

I see now that there is a 2.8 update as of a couple days ago, so I will try and update to the latest version. However I’d like to know if anyone else has been experiencing this problem, and if they found something that fixed it?

Thanks,


#2

Check, if the shift appears once you open/close the door!
There is a known bug with the door switch. In case: just disconnect the switch.


#3

What material?
What print speed?
Are you doing any retraction?


#4

Hi everyone.

I’m not using the enclosure with the door switch, and so that’s not an issue.

I’m using PLA, and I was printing at 40mm/s without a z-hop retraction. I changed the settings down to 20 mm/s with a 1mm z-hop retraction and I have been getting better results.

I had the problem pop up more recently, and couldn’t figure out what the problem is. It turned out to be loose screws securing the print bed. I am going to tighten up the bed and re-level before attempting the print again. I will provide an update once I perform this test.


#5

The layer shifting problems persist. I have tried slowing down the movement, rotating the prints, and adding a z-hop retraction, all to no avail. I have even gone so far as removing the printer from the enclosure and changing the direction of how the filament spools into the printer. However I am still getting random layer shifting despite having different filaments and different models. At this point in time i believe it is either an issue with the printer itself, or Cura. Unfortunately I am unable to get the Snapmaker js application to generate any g-code for me at all. The software freezes often. I am about to just give up, and possibly looking at buying a different printer.


#6

Does it work fine with only 1 file loaded into the gcode?


#7

@zipperjones Sorry for the problem you ran into.
Please fill in the warranty request, and attach a video or several pictures of problem and describe the problem in details.
We will transfer several questions to you from our engineer later and instruct you to locate the problem.
If you have already filled in the warranty request, please wait for some time, we will process your request in 7 business days.
Once the problem is located, we will provide a solution to you accordingly.
The more detailed your description is, the fewer questions we will have.