Maximum Y Position 347mm?

Hi folks,

looked through the forum and could not find anything about it: It seems that the maximum Y position is 347mm (as opposed to my expectation it being 350mm). This caused a problem when I tried to print an object of 350mm size - the back part did not print correctly.

I investigated a bit, and tried this:

G90 ; set absolute positioning
G0 X10 Y347 ; Move (non-extruding) to X=10mm, Y=347mm

→ SM2 moves to Y=347 (according to the display)

G0 X10 Y350 ; now go to 350mm

→ No movement, stays at 347 mm

G0 X10 Y-10 ; now move to Y=-10mm

→ Moves to -10mm

So there are even 355mm of “addressable” print area in Y. When I now modify my slicer profile to have the origin offset, the GCode remains within the -10…347mm window, and all should be fine (print not yet started - will report later).

Also when I use the Jog screen, max Y is 347mm.

So for me lessons learned: Be careful with the slicer profile! Admittedly I basically never slice with Luban - has anyone here ever sliced something of 350mm size? Did it come out well with Luban?
Also: When using CNC and/or Laser, also watch Y-axis for large jobs.

What annoys me a bit is that Luban in the preview has a grid that goes out to 350mm, and there’s no warning that the Job exceeds available print area. Such a warning I’d find useful!

Any other insights that might help?

Btw.: used Prusa Slicer here. Looked quickly into Cura 5.0 - it seems on first glance that I even cannot change the origin… No idea if that becomes a problem when I try Cura next time. On the other hand: Having something of 350mm size is not something I do everyday :slight_smile:

Cheers

Hauke

Updates from my side:

  • Print is now nearly finished and turned out well. So with the offset in origin the print area can be fully used.
  • Tried to slice the same object in Luban. Looked into the GCode, and it goes beyond 347 mm in Y also - so print would have failed! I looked through the header - there’s no coordinate re-adjustment like G92 X0 Y0 or so…
  • Could not find options in Cura or Luban to set origin differently - perhaps this might work as start GCode:

G90
G0 X0 Y-5
G92 X0 Y0

As soon as my print is done, I’ll check if this can be used.

After all, I guess I’ll contact Snapmaker support - basically as it is you can’t use the promised 350mm work area… (yeah, you can, but only using 3rd party software/modifying GCode… That’s cheating :slight_smile: )

Will keep you updated!

So, my startcode suggestion would work - If I do

G90
G0 X0 Y-5
G92 X0 Y0

it sets work coordinates accordingly, and a

G0 X0 Y350

results in this:

grafik

At least in Cura that would be feasible - in Luban I did not find anything for inserting custom GCode…

Have written to Snapmaker support, let’s see what comes out.

My mail to support:

Dear Snapmaker Support,

I recently tried to print an object with its largest dimension being 349.9 mm. With the work area of the A350 being advertised to have 350 mm in Y, I assumed that this is possible. So I sliced the object and started the print - however, the backside of the print turned out to not print properly. Investigating a bit more, I found out that in Y the platform can only move to 347 mm! So when I e.g. do the following:

G90 ; set absolute positioning
G0 X10 Y347 ; Move (non-extruding) to X=10mm, Y=347mm

→ The print bed moves to 347mm If I then do:

G0 X10 Y350 ; now go to 350mm

→ There’s no movement, and the device stays at 347 mm (all displays confirm that).

However, I can do:

G0 X10 Y-10 ; now move to Y=-10mm

This moves indeed to Y -10 mm.

So what I did is transform the GCode so that it prints the object between Y=-5 to Y=344.9 → Print came out just fine.

So in order to use really 350mm of promised work area in Y, I’d think that you either need to modify the internal coordinate system in the firmware, change the limits to allow to go to 350mm (if the linear modules allow this safely), or to modify Luban to use the negative print area.

If I may make another suggestion: It would be totally cool if the workspace in Luban would warn the user if any of the GCode exceeds the boundaries of the machine - that would really help!

Thanks you very much and all the best!

Hauke

Answer:

Hi Hauke,

Thanks for reaching out to Snapmaker. I am sorry that you encountered such a problem.

This is a known issue and we just awarded of this a short time before. We’ve made improvements on both the firmware and hardware. The firmware should be released later.

Have a nice day.

Best regards,
Potter

Add a G92 to the header?

G0 X0 Y0
G92 Y5

G92 is easier

1 Like

Yeah, see above :slight_smile: I guess I confused this threat a bit by answering myself all the time :slight_smile: G92 is definitely a solution, and when I wrote support I made it a bit more dramatic - what I really did is slice again with an offset, which was easy enough in Prusa Slicer.

1 Like

This issue sounds like it might be connected to a problem I’ve experienced after installing the new linear rails on my A350. In my case, a problem occurs when I start any 3D print, where normal first action SM does is to move the rails to an origin with the tool head off the front-left corner of the heated bed. With my original 2020 rails that worked fine. With the new rails, then the Y move gets to the back motion stops and there’s a terrible grinding noise and I have to hit the e-stop button. I’m wondering if the g-code for 3D prints attempts a move to Y=350 at start, and this Y max at 347 is the problem. Do you have the new rails or old? (BTW, with my old rails, and latest firmware 1.14.2 I had no such problem.)

I have the old rails. What you describe sounds concerning - I would double check everything - right modules in right axes, cabeling right, modules aligned correctly, slicer configured correctly… The machine knows its limits and should not bump into any hard obstacle…

OK, printed a 349.9 mm object (longest side) - with using the negative in Y it worked without problems! Also, with 11x11 calibration my bumpy print bed was doing OK, with room for improvement. I guess I’ll follow my plan and try to mill the grid platform to be 100% aligned with X… but that’s another project :slight_smile:

1 Like