Machine not Filling in this Corner

Hi all. I’m not sure what to call this, or the technical name of the issue to even look up, so hopefully you can help me.

I’m having problems with my machine not initially filling in this corner. It’s the starting location where it begins the infill when printing. I’ve messed with the infill overlap which helped with the edge but not really the corner. What setting might help with this? Reaction prime amount?

Just as a heads up, I’ve lost my settings and my machine reset back to default. I’ve completely redone (again) calibrating and setting up my machine. Managed to get close to where I was before which includes calibrating e steps, k value, flow, filament diameter settings etc. Managed to eliminate my stringing issues for 0.16 resolution, but this corner is driving me nuts.

@iAlreadyLost thats under extrusion, calibrate your e-steps and it should go away.

What does a gcode preview look like for it?

Agreed, it’s obviously some sort of under extrusion. In addition to being a miscalibration error, it could also be there’s a low spot in the bed that’s causing the first few layers to be under extruded.

You could try reprinting with a raft and if it goes away then you might have a bed calibration issue.

1 Like

@brent113 if you look really close you can see it’s also happening in the other corner as well, but the view gets blocked by the spike. Not to stray off topic but I’ve requested that they get the e-step calibration summary pinned again, they unpinned it.

@Artezio actually the corner behind the spikes looks ok. That edge is bad though. I managed to fix it in a following print by messing with the overlap infill setting

To everyone, thank you for the replies! I always hate calibrating the machine. It isn’t difficult, just a pain. I’ll give it another go when I get home.

1 Like

this (red circle) should look like the one opposite your thumb (blue circle). It’s showing some under extrusion as well, but not nearly as bad as the other corner. It only piqued my interest and made me wonder why only that side, you see it better than I do though, this is just an observation is all.


1 Like

Additionally to calibrating e-steps, calibrating your k-factor would help closing those gaps.

1 Like

The gentleman said he calibrated kfactor & esteps

my kfactor changed a LOT after the last firmware update. from .06 to .15

@MooseJuice its still under extrusion, what’s up for debate is what’s causing it. Whether it’s e-steps, k value, extruder gear slipping, clogged nozzle, bad filament, or some other cause is unknown. I’ve never had a clog though so I have no idea what.

Yeah. I am not saying it isnt related to extrusion but that he did all the calibration type stuff he said

I think probably a new nozzle would help. It might have a bit of clog. It could be something high on his sheet on that spot too possibly but it would be nice to see the slice. Looks like he is laying out some decent lines around those spots so am wondering if theres an overlap issue maybe too

@Artezio I’ve recalibrated my e-steps, as well as messed around with the k-value. I’m still getting those issues. Oddly, in every print I’ve always had issues in those areas, so whatever it is seems to be reliant. That area you circle with red seems to jar a bit when printing too, despite the model looking straight.

@xchrisd Do you know if that Marlin k-value test can change the k-value on the fly? Last I checked it couldn’t change the k-value mid print. I ended up having to do individual tests for every iteration. Regardless, anything under 0.7 gives me issues, and anything above 1.0 seems to clog the print with a tower. I was at 0.9 but 0.8 seems to print a bit better.

@MooseJuice I recently changed the nozzle, but I might have to do it again since it scraped across the plate. Damn shame though, I feel like I have to calibrate the bed every time and I always do it manually. I might mess with my k-value again. I had my printer working exceptionally well and one of the firmware updates seemed to kill my further prints. :frowning:

I appreciate everyone helping me and giving me ideas on what to try. I feel like the initial line width is actually smaller then it should be. Some of my prints the skirt is really thin and separates when I peel it off (I use 3 lines). Not only that but I changed the pattern of the infill to something different and there’s quite a bit of gaps everywhere. Changing the infill overlap percentage from 10% to 25% doesn’t seem to help.

Also another issue has been popping up is this strange indentation I’ve been getting on a few of these spikes. I’m getting a slightly thinner indentation on the same spot in multiple prints. The only thing I can think of is the indent is right around the same spot the infill stops. On some prints it’s very faint, but I’d like to figure out what’s causing it.

Again, I appreciate the help!

Can you Upload the STL? I would like to try it out on my machine.

1 Like

@iAlreadyLost wow, it’s too patternized to be random extruder gears slippage. It’s like it’s skipping a lot of lines and going to the next ones. Have you tried it in any other slicers? I’m wondering if Curas installation got corrupted since you said it got worse when you changed infill patterns.

Also, did you try factory resetting it then updating to the previous release before it started happening?

Initial line width being thin happens early in the print a lot from needing primed. More skirt = more priming.

The latest firmware, for me, changed my esteps and kfactor a lot.

Crashing nozzle can smoosh it and affect things, not necessarily the problem but can be.

If nozzle crashes during calibration you may need to adjust your proximity sensor… it shouldn’t be doing that. Either that or there could be an assembly problem. I would say this is your biggest problem right now and should be tackled…

What happens if you print this in luban? It would be interesting to see if it comes out differently with a different slicer, because it just looks like slicing funk to me personally.

If you have the STL and tell me the material I’d like to slice you one out of S3d for the fun of it. I am not advocating buying S3D but its amazing the better job it does and the faster job it does lol

I agree with the above said.
Share your gcode please. Did you print 1 bottom layer and then the pins? - This means you need a good bed calibration. - Did you use gluestick or something to get better adhesion?

The Marlin K-Factor test worked for me and i saw the difference.
I stick to 0.1, this gives me a bit overextrusion on surfaces and normally no holes at all.

1 Like

@Georg2 sure thing. The file should be below!

@Artezio I have not tried any other slicers since moving to Cura. I’ll pop it in Luban here after this post and see how it does. As far as updating to the previous release…do you mean the firmware? Cura? My prints seemed to stop working a few firmware updates ago and unfortunately I don’t remember the version that was working well. The only thing Cura seemed to do when I update it was not keep my settings when I requested it too. :frowning:

@MooseJuice I’ll up the skirt a bit more. Like Artezio said though, it seems to follow a pattern, I’d expect deviations with some of it. When I recalibrated my e-steps, I seemed to be around 252 and 248. I don’t remember the point values after. But that was all the range I could find when I did it again. I need to get better calipers, these are not the most accurate and it would help if I had one that had a locking feature. Lol there’s a proximity sensor on this thing? Could’ve fooled me. I’ll give Luban a shot. If S3D is reasonably priced I might not mind. Honestly my biggest hurdle is just learning a new slicer. I’m really familiar with Cura now and I’ve tired of printing these caltrops lol. I’ll add the STL for you as well.

@xchrisd I’ll try uping the k-factor a bit more. I’ll also give that marlin another shot. I just hated setting that damn thing up only to find I had to do it for every value. I didn’t use a gluestick no. The bed calibration was done manually. It doesn’t leave residue when removed but is still completely attached at the end of the print. The only time it broke was actually when the k-value hit 1.0. But that could have been a fluke too.

As a side note, I’ve changed the flow up a little bit more and the gaps are less. Though I’m worried about future problems, would this contribute to elephants feet by chance? Attached below are the STL file and the g-code for the pictures above.

RT.stl (210.8 KB)
RT Good.gcode (2.2 MB)

Try this (1.5 MB)

This is printed with MY setup… so the cooling and kfactor might be weird for you, but see how it goes.

If you waive some metal under that black part that sticks out on the under side of the print head almost as far as the nozzle, it should show a red LED. thats your prox sensor. if you dont see a red led… contact snapmaker. if you do, you may need to adjust the height of it.

furthermore, check this preview out of your gcode:

its not as bad as your final print, but is pretty “loose”

as for S3D - its quite simple to be honest… The profile shared by brent is pretty good for it too. I have used it as a starting point for my own purposes.

It hasnt received updates for a long time, they claim a new version is underway but the community is skeptical. I think it was about 100 bucks maybe 150. They have a “free trial” where you buy it and can return it, but I’m not sure i would trust them to respond on it lol.

With that said, it is a very efficient slicer and is very good for the majority of prints. Thin wall related stuff feels like a weak point for me, and there is no tree support system. They do have their own support system that is interesting though.

I can try to slice a model in luban to cura to s3d, and each one shaves a good chunk of time off. I think a 6 hour print in s3d might take 7 - 8 in cura depending on the geometry… probably more like 10-12 in luban.

I was referring to firmware during that part of the comment, I would revert firmware before anything else. It wouldn’t be a bad idea to perform a factory reset before going to an earlier firmware either. I would do firmware 1.12.2

So this is it in Luban. I couldn’t do the same pattern as before, but it’s at the same layer height. The only issue I can see with the base is it seems to have trouble connecting to the outer wall on layer one for two of the sides

1 Like