Luban V4.5 Beta.8 Supporting J1 Is Available for Downloading

I look forward to checking it out…if i dont end up returning the J1 that is :sweat_smile: i appreciate the response

1 Like

Can we get an update on the Official V4.5 release?

It’s out. If you go to the Snapmaker GitHub page, you can download it.

Sorry, new to github. I don’t see a place to download it. The snapmaker website where you can download Luban isn’t functioning either…

Hi jdubbs, you can visit our Github page linked by @thereisnocat above and scroll down to the end of the v4.5 part. It’s the Assets section where you can choose and download the appropriate version for your OS!

And thanks for your feedback on our website. I’ve passed this message to our team and we’ll address it asap. :blush:

1 Like

Thanks Riskey,

Where is the proper place to report bugs and or to provide feedback for software improvement?

For Luban v4.5, you can write in this thread:

For other Luban versions, you can create topics in the Snapmaker Luban category.

1 Like

I got your email but there were no attachments in it.

Hi BStarry, the email I sent shows like this:

Could you please check again? The file is not supported to upload in the forum or via messages. So I have to figure out why the attachment failed to reach you via the email.


I double checked your first email to me and there is definitely no attachments. I have attached a screen grab of the email from you.

If it helps, I was able to open one of the tester files that came with my Snapmaker A350T, I think it was the pencil holder and it looked fine. It seems to be anything I’ve imported into Luban and saved in the snap3dp format and tried to reopen that seems to be the problem. I can’t say for sure if I had this problem in 4.4 as well or if this is completely a 4.5 issue.

Thanks for the help,

Hi BStarry, I actually sent an email to your yahoo mailbox. :wink: Have you checked it?

Yep that was the email I said did not have any attachments and that I sent you the screen grab of showing that there was no attachments. I also checked the forum page to make sure I had not missed something there either. So I’ve double checked both places the message has was sent to and still have not seen the attachment you mentioned. :slight_smile:


Hi BStarry, the screenshot you uploaded was not the one I mentioned :face_holding_back_tears:

I sent you another one before:


Hi @BStarry

This is not the e-mail from @Riskey but the notification from the Snapmaker Forum
Please also check your spam folder. Yahoo might have “isolated” the e-mail because of the file attached not being recognized.

Thanks that is exactly what happened. Yahoo, allowed the email to go through but moved a copy with a changed sender name and the attachment to my spam folder.

I appreciate the help,

1 Like

Thanks to Dragos suggestion I was able to find your attached file in my spam folder. Sorry for not thinking of that earlier. When I opened your attachment in Luban 4.5 it says that the boat needs repairs but previews just fine and shows the 3dbenchy1.stl file in the object list.

Right after finding your file worked, I imported one of my Blender generated stl files, saved the project and reopened it only to have the same blank Luban Object List and preview again. I will email you the stl file I just used to see if for some reason that is the issue and you can figure out what might be the cause.

As a side note I did a test with a dxf, a svg and the same stl file listed above, into the CNC portion of Luban 4.5. I saved the project and reopened it to find the Object List information and preview was retained just fine.

Thanks to you both for the help,


Per my note I’m attaching a Blender 3.3 created stl file that I have imported into Luban 4.5 and that is not saved with the project is saved.

I have also attached one of the saved Luban 3D print projects that does not retain the Object List information or preview.

The 3rd file is the CNC project that I imported a number of file types including the stl file that did not save in the 3d print project that saved and reopens just fine.

Let me know what you think/


1-2 Knee A 10-24.stl (67.6 KB)

This system did not like the attachments I sent via response email. They were the nonworking snap3dp file and working snapcnc file I attached in hopes they might help.

I did some further experimentation. I found that if.stl files exported from Blender 3.3 had any other errors other than overhanging faces reported in Blender’s “3DPrint” function, the files are not saved in the saved project. This occurs even if the “Repair” function inside Luban is run on the files as they are imported and G-code is generated and the objects look fine in the preview. Further, if there are non error files (other than overhanging faces) are imported and saved in a project, they show up in a reopened project just fine. If you then include a stl file with errors (Repaired) on import, the error .stil file will disappear upon reopening the saved project but the original non error files will still show up.

I’m wondering if now that Chinese New year is over and this site is back up and running if there will be any updates to the issues posed last month. Thanks.

Why is the build plate not 300x200?
My model is 197.5 x 186.8mm