Luban Text Features Severely Lacking

In the Luban software, version 3.12.2, Laser use.
Entering text does not let you do multiple lines, only single line?

There is no longer the option to align text (Left, Center, Vertical, etc.) as in previous version 3.8.

Text font selected in edit mode changes to random font in process mode??

I have also tried the new 3.12.3 and still no useful text functions.

Why would these be removed? These are ESSENTIAL text functions.

Also 3.12.2 isn’t even on the Luban list here, but it is the “Stable” release version on the website.

1 Like

Brand new in here. have the font issue also. tried a font in luban and it changed when I tried to generate code.

3.12.3 is the current latest version.

I’d suggest either using a graphics program that actually handles type well.
It’s so much easier and less of a headache.
Luban is seriously lacking in that department, and I really don’t expect it to not.
It’s there more as a convenience for down & dirty use.
Or try lightburn.
Lastly, you can keep multiple versions installed. I have both 3.8 and 3.12.3 and end up using both at different times (Yes, I shouldn’t have to but unfortunately I do prefer some of the features of each. Or should I say the bugs of one annoy me less than the other.)

Why would you not expect the program to do what it is marketed to do?

1 Like

I’ve made a nice living in a form of marketing.
I never expect something to do what it’s marketed to do.
I’m pleasantly surprised when it actually does.

And if you really go back and look they don’t really promise as much as one thinks. They give an impression but really avoid promising much.

You can either be frustrated and consumed by what Luban doesn’t do or find and embrace better ways of doing it.


1 Like