Luban repairing STL file

I use Cura for all my printing. I ran into an issue today where the parsing failed at 99% transfer into the machine. It was my first time printing Nylon so I attributed the issue to the print setting. I changed my configurations, re-saved the STL with F360, rebooted my laptop and printer, closed and re-opened Cura and F360, and cursed more than a few times.
So, I installed Luban to see if it would give me the same issue. I opened the file and received the message that Luban had to repair the file. I selected yes ran through the print settings and saved the G-code. It’s now printing the file. G-code is attached.

How can I find out what repair Luban performed to the STL file? Is there a log somewhere I can look at?

EDIT: I even tried a couple of online STL repair sites, but they didn’t find anything wrong with the file.

There’s also a repair option within the F360 MESH menus. Did you try that?

I ended up having to redraw the part. There were no issues with the second drawing. I think The way I subtracted a revolve from a sphere left a sliver of material that I couldn’t see. I will try the mesh repair next time though.
Thanks for your help.