Luban on Win11 seems to be majorly glitchy

Hey folks.

So far I have only been working with the laser on my snap maker artisan.
And so before i begin my rant, firstly I wish to state that my problems with Luban have been less problematic on my previous pc running windows 10, also that i know how to use the program and have had many successful projects completed prior to these issues but i was using my old PC at the time.
Ok so I’m having big problems with Luban on my new rendering PC ( runs win11).

It’s randomly crashing.

It’s likes to intermittently make my imported files/objects invisible. (they are very briefly visible then disappear and become only a bounding box with nothing in them)

Ignores that I have removed overlapping images/objects in the edit stage and then after i input the process, those overlapped images (i deleted) re-appear when i generate the g-code.

Randomly it won’t let me move my objects in edit mode at all. I crack the shits with it and restart the program which rarely fixes it, it usually crashes the program again.

It sometimes refuses to let me edit/ move/ rotate only a few random objects when i am trying to arrange 30 or so objects for minimal material wastage. (this also happens with only a few objects- quantity doesn’t seem to be the issue)

But I’ve tried to work with less objects and put them together as a single group file in a vector graphic program and just duplicated that a few times in Luban but it doesn’t make a difference.

Anyone got any ideas on why Luban is crapping itself so bad? It’s practically unusable on my new computer. I’m about to just use a different program, cause I’m becoming a mere husk of a human while trying to get this program to do some simple functions. I’m loosing hair at an alarming rate from the furious hairpulling.
My face has become well acquainted with a brick wall a lot lately. It’s seemed like it was a more productive use of my time. :unamused:

Did you mention the version of luban you use?
I’m on win11 fresh install with Luban 4.8.2. I can try to replicate you issue with your file if you’d like.

1 Like

I suspect the issue with this is:

  1. Your physical hardware
  2. Your OS is corrupted/needs a format
  3. Another application is causing the issues - either because it is dodgy line a virus, or chewing up resources, or …

I’m basing this on little information about your setup provided other than Windows 11, and that @nweolu is using Windows 11 with Luban 4.8.2, and I have three very different machines (hardware wise) that are all Windows 11 (up-to-date) and running Luban 4.8.2.

Hardware would be my first guess. Overheating maybe? Dying hard drive? Want to post your specs? Does anything else crash - even even act wield sometimes on your computer?

1 Like

Its your systems graphics and/or performance, but there are options

Hi guys, thanks for the questions. Hopefully this helps answer them.
PC secs
Processor : 12th Gen Intel(R) Core™ i9-12900K 3.20 GHz
RAM : 32.0 GB (31.7 GB usable)
64-bit system
Graphics : NVIDIA GeForce RTX 4080
Running WINDOWS 11 Pro. V 22H2
Has several fast and big Hard drives, some of which are specifically for The operating system and programs only to avoid memory issues down the track.
Built at the end of August, so has fresh installs of all essential programs, including the vector programs I’m using to make my SVG files for laser cutting work. No virus’s or dodgy programs and everything is up to date.
We built this PC to Render and Run VR, so it’s fast and fancy (expensive). It has No bloatware (apart from what comes with Windows) :unamused:
It runs fast and purrs like a kitten.

Luban is running V 4.9.0 . I had just updated it before todays project attempt but I’m having the same issues on the new version as to the previous one (whichever version that was currant at the end of August)

Luban is still crashing and still refusing to complete the programmed G-code as it was set to do.
As an example of the weird glitches, here are some pics of todays glitch.
As you can see in the photos, only some of the holes got a second pass on the laser bed. (i always need to do 2 passes to get a relatively clean cut on the machine)
all those holes were put together in the process as a single layer so it makes no sense why the program chose to only do two passes on half the wholes and specifically favouring the right side holes.
essentially it’s only doing 3/4 of the job
After this session had finished cutting, the Luban software died as it does at the end of every project to date, even on my old PC (that’s if i get that far before it crashes)
I only have trusted programs on my PC and it’s still bare bones at the moment as i have not had time to add all my other favourit programs.
(I was having these problems on my old PC too with an older version of Luban)
Hope this sheds more light on what kind of system i have and versions i’m running

Turn off the embedded graphics controller in the bios, since its an intel board and chipset gonna guess its has the on Iris system, which is why you have about 200MB of your RAM as vRAM and unusable, which means that paltry 200MB of vRAM is what EVERYTHING but games uses. Which is why you bottle neck with complex geometric shapes and the system slows to a crawl, but games play beautifully

1 Like

I’m not asking my computer to do any hard graphic slog with these projects, they are very simple. but I gave your suggestion a try.
firstly we tried to disable the onboard graphics and it caused my computer(upon reset) to not get past the load screen. Had to restart in safe mode to reverse it. Then we tried to do it through Bios which didn’t give the option to do the same through. So we then tried to raise the VRAM allowance up to 5GB. Fixed nothing. I do have GPU accelerated Graphics enabled too. I ran another project through the laser machine just then but it’s still making the same mistakes. I’m watching the Performance monitors and PC is not straining in any way. I’m not convinced that my graphic settings and memory is the issue here. I need to stress that I’ve had Luban crash on my other computer too, running an older version of Luban and on windows 10. When things are disappearing and Luban also crashes on both my old and new pc I’m left wondering if it’s the Luban program itself and not my computers. I don’t know… I have no idea why it’s having trouble working on my computers.
I do appreciate your suggestions on possible fixes btw. I guess we keep asking around.
Any other suggestions folks?

Everything is brand new including hard drives. Have a large SSD’s for the OS. I have a water cooled system and it’s def not overheating. No other program crashes on my computers. Diagnostics came up with no hardware issues. I have no Virus’s, It’s a brand new Install of Windows 11 and every other program I have on it are from trusted sources. None of my programs, nor Windows appears to be corrupt, no other programs crash or have issues including my other rendering programs, Only Luban does. Problems have been similar on old pc vs new pc. Essentially the same symptoms on two different PC’s with different OS versions and two different versions of Luban. Only reason i thought there was a conflict between win 11 and Luban was i was getting more problems than before, the more I use the program on the new PC. As a point of experiment I will run the same project through my old PC and see if is making the same mistakes. But there is no obvious reason why the laser skips a second pass on the little circles only on the left object but does two passes on the right when they are in the same layer and g-code. I don’t get it. Makes no sense to me.
Working in Luban on the old PC still had program crashes and vectors disappearing. Then i moved over to the newly built PC. For further info see my other reply to another persons suggestion.

Downloading 4.9 now to see if I can replicate what you are seeing with VM

Which laser did you choose when you set the machine up in Luban?

Just tried to get the project to work on the old pc. It will show up in the edit stage and even the process stage, but when I click preview… it disappears and so I close preview and try to export it… it won’t allow me. Export G-code options come up light grey and I can’t even begin the project. :weary:
This is becoming a real pain. One thing I did notice on the old PC is 42% of my memory is being sucked up by running Luban which is not surprising given it’s a 10 year old PC and things are beginning to die on it.
I will keep experimenting and see if I can get it to work on the old pc again another day. But for now I’m disconnecting for a few days to get some headspace. Cheers for all the suggestions.

Gotcha just making sure my parameters are the same

I’m using thew 10w laser set to 3 axis in Luban

Old pc is running 4.8.2 and new pc is running 4.9.0. Having issues with both.

What firmware are you running, because I’m going to need to reflash that digitally in the snadbox

Is it sticking at 30% and wont finish the parse? Because updating to 4.9 and the newest firmware, the system hangs at 30% so far its been 30 minutes

This might be trouble ticket worthy

Just hit 30.8% this is excruciatingly slow

36.6% 27 minutes later
44.7% 1 hr