Luban 3.15 update no laser options

Hello. I just updated luban when it requested, and now in laser mode after I import a file in EDIT, and click process it stays there with no options. i get no way to click generate gcode. I do not know if anyone else has this issue, but I am uninstalling 3.15 and reinstalling 3.14 now to see i the issue is resolved.

To update, uninstalling and reinstalling 3.14 fixed the issue.

1 Like

That may be an occasional case. We will keep our eyes on it and collect the feedback.


I’ve got the same problem

May be you need to create toolpath before generating G-code file.

I just tried this, it doesn’t work, how do I reinstall 3.14

Mine also stopped after updating.
I have the download file for 3.14 so I uninstalled the 3.15 and reinstalled 14.

I was having the same issue as everyone else, but as soon as Snapmaker mentioned creating the tool path, I was able to get it to work after selecting the object. The problem I am seeing is this screen was part of the application without having to click on the object you are working with and clicking a button to “create” the tool path. So this is a major shift in workflow that will confuse a lot of people. May want to consider “re-tooling” this in the next update to Luban, or update your tutorial so people know what do to since the work-flow has had a major update for better or for worse.


Same Problem. Also have a problem with the calibration on the image capture. I was able to get it working by manually adding a path. But when I go to start the project the work origin is off. (BY A LOT). and when I try to manually set the origin it over runs my material when I run boundry. Which it shouldnt since I used the camera capture.


Also here, the new version 3.15 is absolute BS you cannot make any adjustments.

Ininstall 3.15 and instal 3.14. As for home, on workspace you click the “play” button at the top left of the workspace screen to use camera mode. If you send via wifi or use USB pen the home point is set differently.


I did I uninstalled 3.15 and went back to 3.14.

The started the project with the play button and 3.15 still stared in the incorrect location.

3.14 works fine.


Good thing I always postpone updates… sounds like I’ll be waiting a bit longer before I do it. Hopefully the kinks will be worked out soon.

Here is the new workflow regarding the Laser G-code.

Snapmaker Luban 3.15.

  1. Import the file in EDIT
  2. Enter Process
  3. Select the pattern
  4. Click Create toolpath
  5. Save the profile after editing it.
  6. Wait the toolpath being processed
  7. Generate G-code file.

Here is a gif file for your reference.


1 Like

I had the same issue. I use camera capture and found no way to generate G code after uploading an image and laying it on to the work image. Also, the red STOP button has disappeared in this version as I liked it to abort the job if the laser didn’t start where I wanted it to. Not crazy about 3.15

my experience is that luban was getting wore with every update…

3.15 does not work like it should… cannot set any options after pressing process…

And the most annoying part is that everytime I open and do not update the next time I open I need to press one ore time “later”… so now before I can use it I need to press 15 times “later” on the update question…

Got a Mac…

anyone has the same problems?

I went back to 3.12

Hello, we will release 3.16.0 soon.
Our software team is working hard on improving Luban.

You can do not check ‘automatically check for update’ in Luban settings when using 3.12.

1 Like