Can't Generate G-code in Luban

I am trying to generate a G-code for laser engraving using Luban. After completing all the steps and creating the required toolpaths I press the “Generate G-code and Preview” button but there is no preview. I also can’t export the G-code.

I tried many different objects and different toolpaths but no matter what I try I am unable to export or preview G-code. I tried different versions of Luban (4.4.0, 4.2.3 and 3.14.0) and I also tried both with my machine connected and disconnected.

Test 3

1 Like

I’m having the same issue. I upgraded Luban, added the quick-swap kit, and upgraded the laser to 10w module so I’m not sure if any of those activities broke the workflow. anyone else having this issue?

Same problem can generate tool path but not Gcode, sounds like I have the same machine setup as you

Same thing for me :pensive:

I have the same issue, any solutions or responses from Support staff?

I as just having this problem. I went to setting in Luban, I’m on a Mac so that was on the top toolbar and changed the machine settings to having the 10 watt