Luban 3.12.3 Does Show 3D Object Button

Luban refuses to load or even show a load botton for 3D printing. I can load cnc and laser objects but even the featured vase from snapmaker won’t load. Here is a screenshot without the fourth button on the left side. Even in the HTML code it doesn’t load the lines for the button. I’ve spent literally hours trying older versions of luban, reconnecting the printer, and searching everywhere. I can’t find anyone with the same problem.

Do you have the 3D Printhead conectet?

Yes and it runs the home position no problem. Here’s another shot:

Oh it also loaded the filament no problem! So it knows the printer head is there.

Shows Luban the buttons when your machine is not connectet?


There is the 3D button missing as you said, I have no Idea why, dont use Luban.
Have you tried usb connection?

Using a jumpdrive? No I don’t currently have access to one. I guess I’ll have to find another program. You’d think after spending over a 1,000 dollars on something it’d work properly but then again the program is free lol

No connect directly to the pc over usb.

Normaly Luban works, at least for the basics.

No I didn’t try usb, that might work. I ended up switching to a different computer and that fixed it. I’m running windows 7 on my laptop and that might have been the problem :man_shrugging: Thank you so much for the quick help! I really appreciate it! I hope you have a wonderful day/night friend!!

Hi, 3ddud3.
I,m new to SM and tried to carve tings first. That works fine! Now I tried to 3D print a file and mentioned what you mean with your button issue. I have the very same problem and other versions of Luban doesn,t fix it.

It seems so that Win7 indeed is responsable for the issue.
I have the same problem with my win7 computer that also doesn,t show the 3d button.
My other comp runs on Win10, and shows the 3d button correct.
The issue has nothing to do with usb or even what else.
Its defenetly caused by the Luban software in combination with Win7

My problem is now, my Win10 computer is placed in the livingroom and my Win7 comp is in my cave where I use my Snapmaker.
Switch the computer to the cave ore SM to the livingroom is no option.
Do I have to buy a Win10 system, that I store in my cave, or is there a cheeper/better solution?

Sorry for my bad english but I am a silly Helmonder as well.

Have a nice print :smiley:

Hi @3ddud3 @Frydai1958 I am not sure if you are using the 32-bit Luban software. The 32-bit Luban software does not support the 3D printing slicer and it is missing there. If you are using the 32-bit system, so that is the problem.


Ah, indeed my Win7 system runs on 32bit.
So that’s the problem.
Stupid enough the alert in the screenshot did’nt catch my attention while download V3.15.1
You did…
Thank you for your reply, I will install V2.5.2.
Thank you so much.


Good to know when found the problem. It is the Snapmakerjs v2.5.2, and here is the link: Snapmakerjs Downloads and Updates - #40 by Rainie