Laser power slider changes both numerator and denominator

When I run laser job from Luban I noticed the power is not always based on a 100% denominator. The denominator changes to match the numerator and in some cases the denominator was less than the numerator. It appears to affect the laser output and it seems to also differ from the touch screen value. Why would the denominator ever change from full power or 100% to 20\40 or 60\60.? How can I set it consistently if both values are changing?

I’d like to know what those values actually are. Why is there a “/”, is it meant to represent a ratio of some sort (75/80)? The values don’t seem to correspond to my preset values at all. (Luban V4.3.2)

Screen Shot 2022-07-13 at 1.51.05 PM

It’s a bit confusing, but in the above image, 75 is the current power, 80 is what’s input and ready to be sent (via the button next to it). You can either use the slider, or manually input in the box, why they decided to put the /, I don’t know, but I guess they felt they had to put something. This is more evident in projects that change the power in the middle, you’ll see the left number change as it progresses, and the one in the input box does not, as that’s a user-input to change the power.

Thank you for the clarification. Also, why the need for a 8 digit number field seems excessive, considering the tight UI constraints for the side panes. So many small UI refinements would go a LONG way.

PS. Not to mention, every time I leave the Workspace and return to it, the values reset to 100%. I don’t know if they’re actually 100, or just a UI refresh bug.

If it means anything, laser input accepts 3 decimal places, so including the decimal that’s 6. :person_shrugging:
Screenshot 2022-07-13 175922

It resets the input box to whatever the current laser power is for some reason.

Thanks for the reply.

That does make it a little more clear, but I swear there are times where the laser doesn’t make a mark at all, I up the power a bit and it then burns like it was set much higher. I also seem to get different results when setting the temp from the device touch screen vs Luban control. That may have been corrected in this final release. I will have to test more for this so I may supply solid examples with supporting info.

Maybe instead of a / they should put the slider and text box on separate lines or clear the text box completely once the value has been set. Only displaying the current setting next to the slider and a blank box.

I am getting more proficient overall, wasting less material on mistakes and getting better results.

Thanks again for your time and insight,


No problem! Asking is one way you learn, the more you learn, the better you get. :slight_smile: I try to haunt the forums the best I can, I’m still learning a few things with the snapmaker, but I do at least have over a decade of CNC experience to lean on. If I can apply it to help others, then after they learn, they can pass it on, that’s my goal. Soon you’ll be teaching new people how to make awesome things.

As far as how results seem different at times, do keep in mind a lot of things (especially organic materials like wood) will act slightly different even in samples of the same. The best you can hope for is to find a good baseline that “works” without too much variance. I know some materials (such as baltic birch) seem to be really finnicky and have a really small window of accepting laser and does not do grayscale very well. However, maple has a large acceptance and can get a good variance in darkness. (also the maple plywood I have access to is in itself strange, the face turns brown when lasered, but the back turns gray! Despite it looking about the same).

Not mine. Work speed field ALWAYS goes back to 100% regardless what it was or what it was set to when printing started. But the speed of laser module itself doesn’t appear to change/revert to 100, stays at what it was set to. So I’ll chalk it up to UI refresh bug. Laser power on the other had seems to preserve the value when leaving and returning to Workspace.

I tried to upload a video showing the values change as you exit and return to Workspace, but I guess you can only upload links to videos.