Laser engraving constant power mode issue?

Hi There,

Have been happily using the A350 for a couple of years and have just updated to Luban 4.9.1 and I’m having an issue with generating G-code for laser engraving.

I have a feeling it is related to the constant power mode option. (don’t recall seeing this option in previous versions of the software)
I am able to successfully export the G-code as per normal but when I engrave, the laser is continuously firing so as well as my design I have a (slightly fainter) engraved line plotting the every move of the laser head in the “white” areas of my design…

I have tried with the “constant power mode” box checked and unchecked, I have tried bitmap and vector files and I have tried to use dot filled rather than line filled engraving… the latter actually gave me a usable result as it is not continuously firing although it does still plot a line from my origin to the start of the design before it begins engraving the actual design as intended… (not ideal)

wondering if this is maybe a bug with the new update or perhaps I’m doing something wrong with the slightly unfamiliar new dialogue box.

another suspicion I have is that it has something to do with the “preset” I have selected? I don’t remember ever having to use a preset before but I can’t seem to proceed without having one selected since the update…

I’ve tried setting up my own preset with all the parameters set the way I want but Luban keeps reverting some of the setting to values it thinks I should use; again, seems a bit “buggy”

I have reinstalled the software but having the same issues.
Any help much appreciated…

1 Like

Make sure your machine is fully up to date as well as Luban. Also double-check your machine settings in Luban, the 4.9.0 update reset them. The latest firmware for the A350 is 1.17.17.

Will do, thanks for the speedy response!

I have the same issues.Have updated firmware and use the latest 4.9.1. Use the 10w laser, have power on 50% for engraving, unchecked the constant laser checkbox and while the laser is busy, see 1% power, 5% power, 6% power, 0% power changes going on with nothing powerfull enough to engrave anything… please fix these issues.

Can anyone succesfully engrave with the A350, 10w laser and Luban 4.9.1? (Windows 11) My machine is pretty much worthless at the moment, thinking of cancelling my order for Artisan.

I had no problems with my 350 with the 1.6W or 10W. Just make sure to upgrade your machine’s firmware to 1.17.17 first before using Luban 4.9.1.

I have upgraded firmware and luban to both latest versions. Do you use constant power mode? Can you share your engraving settings?

I use lightburn pretty much exclusively. I generally only use Luban for testing and helping users. Constant power mode is a bad name, it’s basically the mode luban and the snapmaker has always used. You likely wont see a difference on or off, the new Ray will probably be the only machine to benefit from it.

Good afternoon. I have problems with the 10W laser. Namely, when I load a jpg file and when I adjust it to the desktop of the laser and after that I click Create Tootpath, then I click Generate G code and then image I loaded disappears, the screen only shows desktop, creation time says 0 minutes.

All is updated.


Thanks @Skreelink. issue fully resolved since updating firmware to 1.17.17.
Really appreciate your help. I hope others on this thread find solutions to their issues!

1 Like

Nice that it worked for you. Hopefully it’s all smooth moving forward.

Is there a way to enforce firmware update again? Because I have updated the firmware to 1.17.17, but still encounter lots of issues. Haven’t been able to engrave one single piece of material with the nc files coming from Luban. I have always used luban in the past.

I’ve tried lasering a previously generated NC file, created with 4.8.2 a while ago, which does work, so it is definitly a bug in Luban 4.9.1 in my opinion.

And this is what I get when re-installing 4.8.2…

On the snapmaker, please open settings > about machine and post a picture of the firmware version.


Can you make a small job, confirm the problem on your end, zip the gcode file, and post it here to see if I can reproduce the problem? (4.8 MB)

Sorry, it is not a small job. But in the zip file there there are two files. is created with Luban 4.9.1 and the other using 4.8.2. Used firmware 1.17.17 for both of them and only the one with 4.8.2. worked as intended.

Ohhh! Apparently they added actual grayscale to Luban if you don’t pick a dither option! Nice find, but very tricky to dial in and is only really good on materials that respond to and darken at different levels of laser power.

What it does it convert the image into a heatmap and changes the laser power depending on darkness, and doesn’t seem to have a way to control the range. In Lightburn this is set with Min/Max (max power is for purest black, min is for purest white) and modulates % between them. Unless you want to waste a lot of material dialing in the settings, make sure to use a dithering solution. I suggest Stucki for real images and Atkinson for high contrast/flat colour like cartoons or sketches. :slight_smile:

Screenshot 2023-10-07 152754
If you select None it’ll process in grayscale mode with varying power, any of the other options will dither the image, and use your set power.

Example snippets;

Using None and it varies the laser power;

G1 X174.60 S65.132
G1 X174.80 S70.728
G1 X175.00 S75.584
G1 X175.20 S80.114
G1 X175.40 S82.376
G1 X175.60 S82.557
G1 X175.80 S84.139
G1 X176.00 S89.652
G1 X176.20 S96.654
G1 X176.40 S100.794
G1 X176.60 S103.111
G1 X176.80 S108.771
G1 X177.00 S113.361
G1 X177.20 S119.351
G1 X177.40 S124.847
G1 X177.60 S128.691
G1 X177.80 S131.508
G1 X178.00 S134.191
G1 X178.20 S135.837
G1 X178.40 S139.047
G1 X178.60 S141.644
G1 X178.80 S142.366
G1 X179.00 S143.39

You can see the power dictated by the S# parameter changing with every line, and even very low (I had power set to 100, which is S255). If your material only responds to like, 90% or higher power at your given speed, then none of these lines will create a gradient burn.

Selecting any other option will dither the image, making it dots, as such the laser will simply turn off and on at your given power.

G1 X72.20 S0
G1 X72.60 S255
G1 X72.80 S0
G1 X73.60 S255
G1 X73.80 S0
G1 X74.60 S255
G1 X74.80 S0
G1 X75.80 S255
G1 X76.00 S0
G1 X76.60 S255
G1 X76.80 S0
G1 X77.20 S255
G1 X77.40 S0
G1 X78.40 S255
G1 X78.60 S0
G1 X79.40 S255

You can see the difference in the preview as well, dithered will be broken into dots and lines;

And actual grayscale will be smooth gradients changing power;

Grayscale when dialed in just right can achieve some amazing results, but it’s so time consuming and the organic nature of things like wood throw it off so much.

In Luban 4.9.1 try setting the algorithm as Stucki and use a Line filled engrave. :slight_smile:

1 Like

I will try that again for sure (I think I tried several methods, including dithering algo’s), but for now, I’m a bit afraid of upgrading again. When I have finished the jobs that need to be finished I’ll try again!