Luban 4.0.0 won't turn the laser to 100%

Hello.
I’m new here.

I’ve been experimenting with the laser engraver on the A350 for the last cuple of days. I have not made anything great jet but I have engrave figures and small pictures.

Today I updated to the lates version of Luban 4.0.0 and now my Snapmaker won’t engrave or cut anything. When I press the start button in the upper left corner in the work space, the machine does the job but the laser is almost of.

When I create the toolpath the laser is set to 100%.

Anyone with a good idea to what I am missing?

  • Jonas

You mean when it starts working, the laser module is moving, but it’s not emitting any laser, right?
Can you upload a video so that I can see your operation steps? Thanks!

Thank you very much for your reply!

Yes, the laser module is moving and also emitting laser, but the power is low. So low that it do not engrave nor cut the plywood sample I was testing it on.

I tried to recalibrate the focal length and the laser worked fine during the calibration. So I am pretty sure it is a software issue i’m having. Also because as I downgraded to the older version of Luban all worked as it should.

I will try to upload a video, but I will need to download the new version of Luban again and then make the video. I will try to be swift.

Once again thank you for replying.

Did youtry to engrave the same file with two different versions of Luban?
We look forward to your video. It would be better if we could compare the differences between the two versions of Luban in the video. Thank you!

Hello again W_Jing

Great idea with using the same file but two different versions! I did not try that earlier, but I have now. If I generate g-code in Luban 4.0.1 and run it through the program I still have the same issue. The module is moving but no laser is emitting. However when I use the same g-code in Luban 3.15.2 and run it through the program, it works.

I have made a video as well, but I can’t seem to upload it. I get an error message when I try to attach it to my reply. As I wrote in the Original post I’m new here so I’m sorry for the inconvenience. Are there some kind of special way to upload a video?

Thank you for your help.

Kind Regards Jonas

You can upload it to Google Drive and share the link with us

Hello

I’ve attached a link to the video I made where I generate the g-code in Luban 4.0.1 and run it through that. The laser dosen’t turn on. After that I downgraded to Luban 3.15.2 and ran the same g-code and it then worked.

Kind Regards Jonas

I know the problem: if you start the job from luban (to use the camshot feature) the settings in the toolpath are not used. Check out my screenshot.

Unfortunately I have not yet found a solution that the Snapmaker uses the settings of the toolpath. If you export the G Code and send it to the Snapmaker, the settings are used. But in that case you have to set the work origin over the devise and can’t use the cam capture.

1 Like

Hi there,
you have to disconnect from the Snapmaker and then start using the touchscreen. Then he takes over all Gcode contents.

First of all. Thank you all so much for replying. It really amazes me that you all take your time to try help me out with this!

@Captn91 It did cross my mind that those controls might had something to do with my issue. What I do not understand is that the power settings under the Laser command (as you have marked in red) is set at the same % in both versions of Luban before I run the (same) code. Actually in your screenshot I am using the G-code made in Luban 4.0.1 and run it through Luban 3.15.2 and it worked. Has Snapmaker changed that feature from 3.15.2 to 4.0.1 so that these controls "overrules the generated g-code? I’ve attached a picture.

@Georg2 I tried to run the g-code through Luban and then disconnect the printer. This resulted in the printer running the g-code for a while and then moving away from the work area. At no point could I control it from the touchscreen. I could however also not control it from Luban (as it was disconnected) and I had to switch of the Snapmaker on the power button for it to stop.

Kind regards Jonas

@Captn91 As an addition to my latest reply, I downloaded Luban 4.0.1 once again. And something did actual happen when I turned the power under the “Laser Panel” to 100%! I have now made some tests with two simple squares side by side. The power is set to 100% in the toolpath for the first square and 50% in the toolpath for the second square. (The new in this is, that in all the other g-codes I have made and run in Luban, the Laser has been set to 100% for all objects in the toolpath).

If I set the Laser to 100% under the panel in workspace and then press play, the laser cut the first square at 100% and then the second square at 50%. It even change the % in the panel in Luban. This is what is wanted.

If I set the Laser to 20% under the panel in workspace and then press play the laser cut the first square at 20% and then the second square at 50%.

Also it “leave” the laser power % at the last used value (in the example with the two squares it would stay at 50% after the job is done). Now what I think happens is, that my snapmaker “forget” to “look” what the power-settings is for the first object in the g-code it is working on, BUT “looks” what the power settings is for the next objects in the g-code. It therefor just use the value it is on (which for me was close to 0%). This explain why the g-code made in Luban 4.0.1 is working in older versions. The g-code is fine but somewhere between Luban 4 and Snapmaker 2.0 the power settings for the first object is lost in the translation.

As long as you remember to adjust the power to the value for your first cut or engraving you should be fine, but it would be nice if the Snapmaker would actual run the g-code as it is supposed to, regardless of some settings in the workspace, that has not been touched.

Kind regards Jonas

I watched your video and followed the steps in your video, but I couldn’t reproduce the problem you encountered. Does this position of Luban always show “0/5%” during the working process?
image
When I click ‘:arrow_forward:’ to start work, this place will show a jump from 0/5% to 100/5%, and the laser module will emit light and engrave normally.
By the way, if you use the work origin method to send G code to the screen, will it work properly (with Luban 4.0)?