Issue: Gcode loads out of grid in workspace

Having issue with the gcode loading to workspace but is not centred as it normally would be.
Not sure if this is something im doing wrong or if it is a bug, as I have not used my printer in a while and I just updated to the lastest version before trying to print and now I am at a road block.
Any ideas?
Screenshots showing pre and post gcode load to workspace.
Note: the red arrow on the third screenshot, thepreview shows it fine but you can see the travel line heading up past Y+100
Close the preview and it is just trying to waste my filiment…

I think I may have answered this myself, Looking itn the machine settings, it seems to have set itself to a snap maker 2.0350/350…
Changed it to suit my machine and it’s all “G”.
Is the latest update switching this? If so, would be nice if it didn’t. Or perhaps if it just recongnised the device.