Importing files into Luban

I am totally disgusted with Luban. Having no luck importing a file made in Lightburn into Luban. “Failed to import this object. Please select a supported file format”. Have tried renaming file with .nc , .dxf , .svg and it won’t work with this garbage software. Trying to use the rotary and nothing is working. Isn’t it just a simple renaming or am I missing something. Please help.

Just renaming a file extension is NOT a plausible solution. LOL

What kind of file did you create in Lightburn? GCode? If so, where in Luban do you try to import it? GCode will only work in the Workspace area, not in e.g. the laser job area.

Instead of being sarcastic, do you have a solution…?

Tried Gcode but it doesn’t work either. Is there a trick/process that you could pass on ?

Not much of a trick… just the standard workflow:

  • Design Job in Lightburn
  • Select “Save GCode” and write into some file (standard extension is *.gc - Luban does not have this as default, so perhaps use *.gcode instead or rename later)
  • Open Luban, choose “Workspace”
  • On the top right, click on “+ GCode-Files” and select the file created
    This should open up the GCode preview.

I just tried to import the GCode into the Laser-part of Luban (as opposed to the Workspace). If I try to import the file there, I get exactly the error-message you describe, so I suppose your mistake is to choose “Laser” instead of “Workspace” after starting Luban. The “Laser” section is to design your Laser-Job - this part you obviously replace by Lightburn.

Laser files should end in .nc
Cnc is .cnc
3d printing is .gcode.

-S

Nothing I try works…Not sure what to do. Loaded this file into Luban but can’t get it to show up in 4 axis for rotary… Facebook

I do not seem to have access to that file.
grafik

Here’s a link on We Transfer… WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

When I opened the file you linked, it came up in 3-axis mode. Marked all with Ctrl-A and did copy, switched to 4-axis, pasted - works:

So, can you describe a bit more what exactly you do and where you fail? More detail would help others to help you…

That explains why it didn’t work for me. Copy and paste…who knew. So why is it just 3-axis instead of both 3&4…? There is no Tutorial or Owners manual for Luban and I haven’t messed around with it much as I have been using Lightburn. No idea how to create a project in this crappy software but it’s the only one that works with the rotary or I wouldn’t use it…THANKS FOR THE ASSISTANCE

So I followed the copy/paste but it won’t allow me to resize it to fit…Any ideas

Had the same - Luban only allowed me to resize the individual objects (each square etc.). I looked for some grouping function, but could not find anything quickly. I usually do not use Luban for such stuff, since the Software is too simplistic for my taste. I’d say: use Lightburn, but I am not sure if Lightburn supports a 4th axis - I do not own the rotary module and had no need yet to dabble in the 4th axis. Having a very quick look on the internet, it seems that Lightburn supports it: Rotary Setup - LightBurn Software Documentation - since you seem to own Lightburn, try there, the software offers much more features.

Same problem…There is a “Padlock” but it won’t allow it to be UNLOCKED for resizing. Almost like a “Owner” feature that prohibits editing. As for Lightburn, the rotary feature does not work with Snapmaker rotary and I can’t get any file created in Lightburn to work in Luban… No one seems willing to tell me how to get it to work.

It would really help if you would describe your problems in more detail. From just one sentence it is really difficult to infer what exactly you are doing and where you might go wrong. What e.g. do you mean by

Did you try the workflow I gave earlier in this thread? I did several projects in Lightburn and had no problems running them on the Snapmaker.

Some of your questions suggest that you struggle with the concept Object → Processing → GCode → Luban Workspace → Snapmaker Device, but I may be unfair with you here. Let me know if it helps you to elaborate on this more.

As for the padlock: Is that in Luban or Lightburn? The padlock may indeed mean that the objects are protected against accidental modification, but typically you have some place to “unlock” them. What is the actual source file you based your project on?

See here: Lightburn + Rotary Guide

Padlock is in Luban Edit section… And there should be a way to unlock it for the whole file but Luban sucks LOL. The source file I sent the link to came from Facebook Snapmaker Owners page in the Files section. As for the link you sent I didn’t know about this “Full control” with the rotary. I am not very comfortable with editing code but maybe that’s where I should start. A lot different than Diesel mechanics that I retired from.

That symbol means that the aspect ratio is locked, i.e. the ratio between X and Y will stay the same even if you resize the object. This is very helpful if you want to resize a circle or a perfect square and want to be sure that the resized object remains a circle (instead of becoming an ellipse) or a square (instead of a rectangle). Just clicking on the padlock symbol toggles the interlocking.

I can understand that and looking into the thread I linked I see that they even suggest to install a custom firmware, which may be risky. But as far as I understand this is only if you want to run the job directly from Lightburn. To my understanding Lightburn should be capable of producing valid GCode for the rotary. Perhaps with GCode edits - GCode editing is very easy, so don’t shy away from that. Since I do not own the rotary I cannot give you first-hand advice, but perhaps you could contact some of the experts from that thread?


Who?

Anyway. It should be noted, while it seems daunting, gcode is actually quite simple. Outside of a few specific commands to control it (such as G90 for absolute position, G21 for using mm, etc.), which can generally just be quickly searched as needed, most of it is literally Point A to Point B. The header and footer will be the main setup/safety/informational gcode lines, whereas the bulk is going to be G0/G1 commands, which are both linear movement commands, where G0 is usually ‘rapid transit’ or non cutting/lasering/extruding lines (moving the toolhead one place to another quickly) and G1 is the movements that do what you want. i.e. G0 X10 Y10 moves the toolhead to 10mm in X and 10mm in Y from the origin. Unless you’re in relative mode, then it just moves that far from the current position. (of note, Lightburn uses relative movements after going to the origin, whereas Luban uses absolute) A simple square looks like this in absolute;

G1 X0 Y0 ; Moves to origin, usually lower left corner.
G1 X0 Y10 ; Moves 10mm in Y (the bed)
G1 X10 Y10 ; Moves 10mm in X (gantry)
G1 X10 Y0 ; Moves back to Y0
G1 X0 Y0 ; Finally returns to start.

and like this in relative;

G1 Y10 ; Moves 10mm in Y (the bed)
G1 X10 ; Moves 10mm in X (gantry)
G1 Y-10 ; Moves -10mm in Y
G1 X-10 ; Moves -10mm in X

If there was an M3 S255 (M3 is laser/spindle on, S# is power, 255 being 100%) before it, and an M5 (spindle/laser off) after it, that would engrave a 10mm square. Absolute is easier to wrap your head around as a beginner, as the X/Y numbers corelate with exactly where the toolhead is. Once you actually begin getting into it, it can get addictive to go “what will changing THIS do?” Plus most of the edits in my guides are just “replace A with B” kind of things, so no gcode knowledge needed, just gotta change a few things so the machine understands it. (A is what Lightburn uses for GRBL rotary, whereas Snapmaker understands B, it’s the same thing technically)

The reason these are needed in the tutorial is the fact that it generates what it thinks is for a GRBL machine. There is an option for it to spit out snapmaker gcode with the rotary, but I’ve actually not used it. :upside_down_face: I’ve done the full custom thing because the results are so much faster and cleaner. If you follow them step by step, you should be fine, even with the custom firmware. Only one person has had a problem with the custom firmware, and that was because their touchscreen was crashing the main control app when they tried to update the firmware and they tried to fix it on their own. However, support got their machine back up, and they tried again and it went through the second time. We think it was crashing the first time from a bad USB drive. It’s worth noting that “custom” firmware is a bit of a stretch. All I’ve done is compiled from Snapmaker’s github and edited out one merge. It’s otherwise still stock. Mainly because the inline feature of Marlin is on their github, but their official releases use an internal build without it. :person_shrugging:

You can also ask questions in the thread and I, or others, will try to answer the best we can to help. Here’s a stickied post containing a lot of guides that should help;