Image disappears when Generating Gcode

On occasion, when I “Generate Gcode”, the image of the 3D Print disappears from the screen (i.e. the multicolored sliced rendering is no longer on the screen). Essentially, the workspace is blank. I figured the slicer just couldn’t handle the size or the complexity of the *.stl, so it bombed out. After a few of these instances, I randomly “Uploaded to Workspace” and looked in the Snapmaker window. Again, no image.
Then I hit “Run”, and lo and behold, the print started and several hours later, it finished!

Bottom line . . . . the file is there, but it cannot be displayed in either window.

What am I doing wrong?


  • Send me the STL you failed to process.
  • Send me a screenshot of Snapmaker Luban.
  • Tell me the version of Luban you are using and the specs of your PC.


Here is the workspace:

Here is home window:

Here is the PC Sys Configuration:

The disc space available is 209GB out of 284GB.

The file is 4,746KB, which is slightly larger than what can be uploaded here. So I zipped it. (2.3 MB)

What was the solution.

Since latest update I have had the same issue. Workspace never displays graphic.

1 Like

I upgraded the RAM and moved to Windows 10, but I haven’t been printing too many large projects lately, so I’m not sure the problem has been actually solved. I do think it was limited to just one of my laptops and I did swap to a different laptop, so again, I think more RAM and upgrade to a newer Windows OS will do the trick.

The issue is not limited to 3DP. I am using the laser to engrave glass and have the same problem since updating to 4.1.3. Before updating it worked perfectly. My system is 8 core i7 with 16gb ram of which 50% is free and CPU is less than 10% used. See attached task manager capture.

|Processor|Intel(R) Core™ i7-8550U CPU @ 1.80GHz 1.99 GHz|
|Installed RAM|16.0 GB (15.9 GB usable)|
Hard drive has 221GB available

Attached a screenshot of the blank workspace.