I need a post-processor config file (.pp extension) for Vectric's Aspire CNC program

As we are working on improving Snapmaker 2.0 machine, we only offer post-processor file for the mainstream CNC Softwares, including Fusion 360, ArtCam, and FreeCad. If the need for the corresponding file for Vectric’s Aspire CNC program is huge, we can make a plan to make it due to it needs much time to do it.

I have recorded your request and forward to the tech team, and I cannot assure you that we can do it right now.

1 Like

Thanks for your feedback!

snapmaker-aspire-configuration.zip (7.4 KB)
This is the post-processor for Vectric`s Aspire CNC program.Instructions and notes in the README.md file.
It should be noted that the “Feed rate” and “Pass Depth” of the Tool Database,It is recommended that the “Feed rate” should not exceed 600mm/min and the “Pass Depth” should not exceed 0.4mm.

Subsequent updates will be posted on

Looking forward to your feedback again.

How well does this work. I have looked along time ago and then stopped my searching. I have carve desktop will this work

Can we bring this thread back to life. The post processor seams to work. But when i try to transfer the file from the sod card to the lcd it refuses to transfer it tries but no dice

Hallo Edwin
As you say ”if there is enough interest” to have a official post processor for vectric software, i’m also very interested (together with some others that i know)
As you have made a 3 in one machine, this would be nice for the laser module also
I saw some comments on the vectric forum about snapmakers compatibility with their software, but with different outcome.
So it would be very welcome to have a official post processor from you guys
Thanks in advance

Go to our GitHub page, and we have released some post-processor for Snapmaker 2.0.

If you need other kinds of processor, please do not hesitate to pull a request on that page.

1 Like

Unfortunately it is not possible to import Snapmaker tool database into Aspire 9.512
you always get ERROR: Tooldatabase written by later version of proramm

so where is the newest file i do not see it in the github page

Assets folder

Thank you very much.

Gonna try it out this weekend

Vriendelijke groeten/Best regards

Hugo

i found it thanks im goin to try to see if it has fixed my issues thanks

I use the “Snapmaker_cnc_mm.pp” and have a lot of false Pathes. When i use geometrical forms.
Text is clean and smoth. But when i try to use as exp. a squar with rounden corners tge path i can see in Luban when i import the cnc file is realy worse a lot of big circels on teh corners, So i can not use aspire which is realy a pity.

Also see this topic:

Either the postprocessor isn’t correct; there’s an issue with arc moves; Or there’s a bug in Aspire. I’ve debugged part of the problem, but I’m not using Aspire (and don’t intend to) so it’s up to someone else to try and fix it.

You can manually edit the files using a tool like ncviewer to see were it goes wrong (see linked post) or in a lot of cases just remove them without too much of a problems in the end results.

According to the github page:

the issue was solved. If it still doesn’t work for you either there is still a bug. In that case report it.
Or you’re using an outdated version of the post-processor.

Or Aspire has bugs.

Anyone having trouble with the PP? I finished up a project and started exporting the Gcode and it seems to be stopping and staying still for several seconds then moving on. Keeps doing it over and over, it’s adding a ton of time to the build. I’m using Vcarve Desktop, PP from GitHub, and loaded tools from GitHub.

Today I tried to install (into the newest version of Aspire, Trial Edition 10.5) the Snapmaker tool library and post-processor from the Github site and got the errors described here:

Any hints or tips on how to get past this error? Thanks!

1 Like

Woohoo! I solved my own problem by downloading and installing the right files properly from the Github site - click through on the .vtdb file until you can download the 112 kb file with the tools, and then copy the .pp file content into a simple text file, rename it with a .pp extension, and then it installs into Aspire no problem.

15 minutes later, I proved to myself that the Aspire generated and post-processed .pp file works with the SnapMaker 2.0 A350!

1 Like

Looks great! Do you plan on sharing the file? Congratulations.

Best to always go to the Github site to get the latest; can’t upload that file type here, eh.

It is always best to go to GitHub, but there is a workaround so you can actually upload any file type here, just have to zip it.

-S

2 Likes

Please report any issues regarding the post-processor files of Snapamker 2.0 machine.

Cheers
Edwin