How can I tell if my laser is bad?

I’m starting to think maybe the laser I got is bad. It seems 100% random if it is going to work, with a higher chance it wont. Without changing the picture, settings, etc. Using the exact same file on the exact same sample. I found many many many times it is pretty much like nothing happens. Then when I connect it to my computer and tell the machine to up the power by 2%, it about burns a hole in the wood.

Like I’ve been trying this for I think about a month now, and I’m to the point of just asking support if the laser is broken.

I’m using a SM 1 with a 1600mW laser. I’ve tried doing poplar, pine, cork, and balsa wood. All giving me a hit or complete miss. And by miss I mean you can’t even tell the laser did jack to the wood. When it’s a hit, it could be too much or about perfect (and again this is without changing settings).

Is there any trouble shooting I should use? Like I’ve done my best to make sure the beam is as small as it can be. Maybe it needs to be cleaned? How would I go about that?

Hey @crua9, what kind of software do you use for laser engrave?
Software Version?
Hardware,- NEW Enclosure? Door-Detection-OFF?
Maybe you try the square-test image, this should be with various laserpower-settings from softwareside.
Try a other USB-Stick, USB-Cable and USB-Port
If the latest software is running correct, there would be a hardware issue…
Do you have a second laser toolhead?
Is the laser toolhead recognized correctly?

For whatever reason, I didn’t think of testing the laser that came with it. Anyways, I just got done testing and I’m still getting inconsistent results. To the point on my last test it doesn’t look like anything has happened at all. It seems to make no difference

As far as the version. I have the newest on the machine, I have the newest enclosure with the sensor (I bought it a month or so ago and it already came installed). The USB stick seems to not matter since I’ve had the same result with directly plugging into my computer.

As far as the test. I’m assuming you’re talking g about the one on luban. I didn’t know that has different power levels. I might try that later. With that being said, it seems like I can get good results with things like vectors (where the laser is pretty much always on). Like these I do the least amount with. But the one I use the most often is grayscale

Hey, maybe you try an older software of snapmakerjs or luban.
look at this post:

for more support maybe PM @parachvte

The more I’m looking into it the more I’m thinking it’s a focus problem. After looking around a bit, it seems a good number of people ran into the exact same issue. This is making me iffy if I’m going to keep my pre order since IDK if it’s a general problem with the type of laser. Like I tried acrylic and ran into the exact problem with each of my test. Where the laser didn’t do anything to the acrylic. And this is after a good 10 or so test to get it working.

I’m thinking maybe it’s under power for what I need. And sadly, it looks like SM 2 has the same power rating as the 1.6 I’m running now. Maybe the auto focus will be what I need

Two main points of this issue:
1, You can turn on or turn off the laser beam with “M3/M5”, which shows that the chip for it is intact.

2, You can load and unload the filament successfully.
The test shows that the main controller is intact.

Here is one picture that shows the 1% of laser beam.

Also, you can try to engrave a grayscale file to test if the power can change normally.

1 Like

Thanks for the heads up. Based on this test it looks like the controller is good. M3 made it bright, and M5 turned the laser off.

As far as the grayscale test you sent, I can’t do it because it is too big. The biggest sample size I have on hand is 100x100. Your test was 200 wide.

As far as the picture, I’m interested in it since the beam looks wide and much like the one I get. How is the auto focus on the new machine by the way? Is it good? I only have the SM1, but I have the A350 I think on pre order.

I am sorry I made a mistake, and I thought you have Snapmaker 2.0. As for Snapmaker Original, you can use the command “M3 Px”, the value of “x” stands for the power you select. You can have a small power like 1% or 5%, and try to burn a piece of paper or poplar. The grayscale file test is also applicable.

1 Like

Most of my stuff is poplar. What settings do you use?

I’m working on cork right now and it’s a night and day with the results. So maybe it’s a setting or focus issue. Maybe both?

Please refer to this link to read some articles of the laser module.

If the problem remains, please make a video and contact for further help. You need to send the video and the settings you are using.

Snapmaker Luban is not compatible with Snapmaker Original now. You need to use Snapmakerjs for the test now. But we will release a new version of it for both SM1 and SM2 in a few days.

Thanks. I didn’t know that about the program. I will try SMJS now.

As far as the setting, the guide doesn’t have poplar

Also, do you have any tips for acrylic? I’ve tried the settings in the guide, but it doesn’t seem to do anything. I followed the settings in the guide, but it is as I didn’t do anything. I might be doing something wrong since this is a first for me.

@crua9 maybe you look for it at the forum or use trail and error.

I am sorry i misunderstood you, i thought there is absolutely no laserbeam coming out.