Help! Snapmaker Ray 40W and Lightburn won't work with many issues

This is a brand-new machine plagued with so many issues. I don’t have an enclosure. I spent a good part of yesterday loading new firmware, uninstalling, reinstalling, etc. I tried Luban (horrible software, I hate to say), and even if Lightburn recognizes the machine, it gets stuck trying to connect.

I’ve tried different USB ports for the laser and unplugging other things on the port, but even with the latest firmware, Lightburn will not work with Snapmaker. I’m running Windows 11 by the way.

The machine connects with the Luban software, but if I try to engrave/cut anything after going through all the painstaking steps, the machine errors as it hits the limit switch and is only on the left side. I tried to play around with the offset but I can manually move the laser head to the very left and it’ll beep with the red light on the button flashing until I move it manually away from the left Y-axis rail. Then randomly, if I hold down the button for three seconds after moving the head manually, then it’ll suddenly start to engrave.

I’m so disappointed as it looks like a nice machine, but before I give up and send it back for a refund, does anyone have any ideas?

I can well understand your frustration - I also recently got my Ray and have to say that the documentation is more than incomplete and you could really despair on some points.

But - the product is really very, very well made, the price is very good, and there is an appropriate housing, which was very important to me for safety reasons.
A laser is ultimately a dangerous tool and if you’re not careful, you can get into big trouble.

So if you really want to go ahead, I strongly recommend that you buy the matching housing. You only have eyes, for example, once … It’s also a good idea to combine the housing with an appropriate ventilation option - depending on the material, very foul-smelling and, above all, possibly toxic vapors are produced.

And now to the basic problems. When I read your post, I assume that you stumbled across the similar problems that I also had.

If I have understood correctly, you have probably been able to install the latest firmware with Luban.

The device runs with Lightburn in any case. If you change the connection from Luban to Lightburn or vice versa, you must always switch the laser completely off and on again, otherwise it will not work. You need to connect to Lightburn via USB. Wifi for Lightburn ist not supported.

There is a post in the forum where you can download the necessary definition file for the Ray and Lightburn. You can use this to make the device known in Lightburn. I assume that you have already done that. Here I use COM4 to connect to the Ray.

The settings can be a bit confusing at times - it took me a while to understand them halfway.

My settings are as follows (I have marked the most important areas in red):

You can then trigger the reference run in the laser section. This moves the laser head to the rear left, as the Ray has its reference position there.

If you do not set the Origin (and the Offset - see below) correctly, the buttons under Movements will work mirror-inverted for up and down, which is very confusing.

You must now use “G10 L2 P1 X0 Y-400” inside the Lightburn-Console to set the correct offset of the coordination system (permanently), so that you can use homing and absolute positioning. This setting is permanent until you change it - see next paragraph …

You should use “G10 L2 P1 X0 Y0” to change back to the standard offset of the coordination system - as far as I know Luban does need this offset to work properly. You should check the forum carefully for further information to not damage your device running outside the boundaries !

If you have set the offset correctly and triggered the reference run, the laser will move to the correct position which is in the rear left. You can check this here:

The Buttons (3) should now work properly:

  • Arrow down moves the laser head forwards
  • Arrow up moves the laser head backwards
  • Arrow left/right moves the laser head left or right

So much for today - I hope it helps you a little further

3 Likes

Whoa…if every forum was this helpful. I very much appreciate it!

I’ll give it another try this weekend and report back. Again, thank you. At least I’ll know if it’s me or the machine once I give everything a try.

urmel, thanks again.

Over the weekend, I played around with it more using your setting, and while it’s a hair different for the axis, I was able to run Lightburn without it fouling, for the most part.

What I’m trying to figure out now is why I can’t cut or engrave from edge to edge. What I mean by that, if the bed size is 600x400 on Lightburn, I need to put my design about 20mm away from all the edges. Otherwise, the operation stops as the machine thinks it’s gone beyond it’s limit or near it.

Aside from that I’ve cut several sample pieces with a 6" vent going outside (I work out of my shed) so that’s been working well so far. I’m thinking of getting a honeycomb bed as I’m not finding the bed that came with this unit particularly great with the way it traps residue and smoke blowing out from the sides.

Hello

I’m very pleased that you’ve come a step further and yes, there’s still a lot to discover and try out.

The honeycomb base is still a bit tricky - you have to make sure that the laser can go anywhere and that the base itself is not in the way when the laser is moving. Especially if you have the base on feet, this is something you should definitely check before starting the job.

The base supplied is 600x400, which is the maximum possible size for the Ray. In my case, it fits into the laser without any problems and it also has enough space to the sides so that the laser can process the full size.