Snapmaker 2.0 A350T and Lightburn

Hey y’all, I have been trying to mesh my Snapmaker machine and Lightburn up and it has truly given me difficulties trying to get them to work together. I have put the gcode in that is suppose to work for it but it engraves too high (.5 or .75in too high) of a level meaning the z offset is messed up. And yes I can put in that the material is 0mm and it will be too high still anyone have any idea how to fix this issue?

You can’t set the material height in Lightburn unless you some specific things. You have to set the height snapmaker’s way. Either via the touchscreen or Luban. Any height in Lightburn will be added on that and mess it up.

When I set the height on the touchpad it will just be overwritten by what Lightburn when I tell it to start the job.

Lightburn just puts a G0 Z#, if Luban already moves it and sets an origin, it’ll move that much differently unless you set Z0 appropriately. Setting the height in Lightburn only works if you bypass Luban or the snapmaker interface.

Yeah that’s what I’m doing, just running Lightburn directly to machine.

You can try to run through my Lightburn control guide then if that’s what you’re wanting.

I’ve been through that whole and added all the stuff you did and I’m haven’t been happy with the results. So your telling me I need to change my z offset by changing z#?

Wait, you might have been hit by the latest bug we’ve found. Read the last few posts in the lightburn guide.


Hey some my laser height actually want messed up it was the speed at which was I running it at. So now I’m wonder how fast you’re running it? And also do you have Snapmaker a350t?

I have an old A350 and an A350T. For travel moves I run 6000 and 9000 mm/min respectively. For quality, I engrave around 2000, but I’ve seen no issues with higher speeds as far as Z height.