Full Lightburn Control Guide

Currently I’m not sure what I need to install or set. As written above, I downloaded the file V1.18.2.bin because I suspect it is the last one.
Now I don’t know what else I have to do/consider other than installing V1.18.2.
At this point I only get the message that the transfer was faulty because the machine is busy or stopped. I’ll try to add a few screenshots here so you can see where the current error is.

hello and thank you for your help. I still have a question: How do I insert images here?
Thanks for your effort!!

I mean the built-in Template/Preset/Controller Language to choose when setting up the device via the wizard in Lightburn. Among Marlin and various GRBL flavours, there is also a dedicated SnapMaker option.

I hope Snapmaker took the compatibility-problems seriously since this tutorial was written and updated their Firmware to integrate better with Lightburn out of the box without having to use altered FW and extra gcode.

I still have several issues with the Snapmaker-“Preset” which I have to work around. Not sure if they are caused by limitatations of the Firmware or by my limited understanding of the configuration within Lightburn. Examples are laserhead Z-diving into the bed if I dont calibrate the A350 each time I start it up, Autofocus not working, Camera FOV not staying consistant after restarting Lightburn etc.

This threat is great, dont get me wrong. Its just hard for me to follow what issues have already been taken care of by Snapmaker updates over the last 1 1/2 years and which still need work arounds.

If you want to follow the guide, make sure to read through some of the later posts for some updates on the method. You do NOT need the custom firmware anymore, just make sure you’re on a recent version, 1.18.2 is fine.

As for the error, it sounds like an odd one I haven’t seen, I will definitely need some images. To upload images, press this button;
Screenshot 2024-01-30 162520

@Thorus Use the base GRBL, that’s what even the official snapmaker profiles use now. I discovered this in my post here;

The only caveat is if you’re using the rotary, then you’ll need to use the Snapmaker profile.

1 Like

Uploading: IMG-20240130-WA0002.jpg…
Uploading: IMG-20240130-WA0003.jpg…
Uploading: IMG-20240130-WA0004.jpg…
Uploading: IMG-20240130-WA0001.jpg…

1 Like

The [quote=“Thorus, post:425, topic:27638”]
dedicated SnapMaker option
[/quote]
Is useless.

I’ve been successfully using the same Marlin profile for the 1.6W, 10W and 20/40W

1 Like

Hello and good day.
I assume that if I don’t see my pictures here, they still aren’t there
available.
In the meantime the controller of the A350 also gave up the ghost. The message I mentioned is still the same. I tried other cables. No change.
So I’m still trying to upload pictures. (does each have to be uploaded individually?)

You can try uploading the images to a website like imgur.com and posting the link here.

Uploading: lightburn benutzung.jpg…

There are my screenshots

I haven’t seen that one, but I don’t use USB. However! I know the snapmaker isn’t in a ‘ready’ state until you home it the first time. Turn the snapmaker on, then on the control screen go to the ‘control app’ and let it home. Then try to run your project in Lightburn.

EDIT:

Thank you for the hints. I fixed the issue with the error message. The USB port has read every UB stick. Windows also signaled me acoustically that it was connected to the Snapmaker. In short, it was the USB port.

I have the file"
snapmaker-2.0-40w-v1.lbdev" and supplied it to Lightburn. I hope that wasn’t the next error. Now I’m still not sure what should be entered in the beginning and end of the G-code / must.
Is the “Marlin” setting correct?

@Skreelink you are amazing.
I had go thru this post from the top and would like to understand more about engraving photo. With your explanations, you use the term ‘Luban old style’ (or something like that) which is every single dot the laser fire for 5ms (default) then off and move to the next which this style take many line of code and that cause slow.
Now, I understand that the in line mode take many code pack in just one line. But I don’t see, how the code tell how long the laser head stay in that position before turn off power and move to the next dot?

and another parameter is the speed input? What its role and how it tanslate into gcode for this dot photo engraving.

Thanks in advance :slight_smile:

In the gcode for a dot-filled engraving, you’ll have an M3 S# which turns the laser on at your power, then a G4 P# which is the dwell time, and then M5 which turns the laser off before a movement command to the next dot.

Inline it simply turns the laser on and off for each dot without stopping the movement, which is a lot faster.

1 Like

Question about the Laser Height ftom the homescreen.

I’m playing around with the DIY rotary project using the 10w laser head https://www.instructables.com/DIY-Rotary-for-Snapmaker-20/

Would I be right that if my laser height at 39mm and I add the height of the top of the rotary wheels, another 35mm, the laser head should not crash into the DIY setup?

Suggestions and comments welcome

Regars
Graeme

Laser drives into the table!

Hello and good day.
I did a little reading and proceeded as follows.
Snapmaker set to a zero point that I can use. X,Y and Z
Entered x0 y0 in LB G92.
Place a square in Lightburn in the corner 0 / 0 and let the square move.
A350 and computer restarted.
Snapmaker set to a zero point that I can use. X,Y and Z
Retransmit the order with the square to the A350.
The A350 moves in x and y and then drives into the table in Z.

Where am I making the mistake in thinking? Can you help me?

Best regards

Translated with Google

Hi Everyone! LightBurn chiming in here.

It appears that with a recent firmware update, all Snapmaker devices (not the Ray, which already was GRBL) now present as GRBL devices, rather than Marlin. This has the lovely benefit of breaking comms with LightBurn until a new device is created. Any Snapmaker devices currently using the Snapmaker Device Profile or Marlin device profile in LightBurn will no longer work after this firmware update.

LightBurn users need to be especially aware that if you want to avoid black borders when carving images (using non-Greyscale image types), you need to add M4 S0 to Start Gcode due to these changes

We recommend that all users use the LightBurn Grbl profile (and provided .lbdev files from the Support page for your specific Snapmaker Device) and not the built in Snapmaker one.

What’s worse, this means that rotary will not work for anyone who has the latest firmware because LightBurn has Snapmaker specific logic for Rotary. If you use the rotary axis with LightBurn and your Snapmaker, we do NOT advise you update your firmware at this time

Note: Devices even get discovered as Grbl now via Find My Laser, NOT as Marlin or Snapmaker.

From our Snapmaker contacts:

the new firmware has been out for a while now (v2.5.21 was released on 20231013). Also of note, we released an important fix related to lightburn in v2.5.23.(We strongly recommend that users upgrade to this version and it has been released)

2 Likes

Odd, I’ve been using the same Lightburn Marlin profile for the 1.6W, 10W and 20/40W on the latest Snapmaker firmware (1.18.2) without issue. Snapmaker 2 A350.

This firmware is only for the Artisan machine.