Extrusion just stops after a very short time

It’s been a couple of weeks since I used my Snapmaker.
Last time I used it, I did several 3D prints which worked fine.
Today - it stops extruding after about 15 seconds. It continues moving the head, just no PLA is coming out.
The feed isn’t blocked or jammed. If you stop the print, and restart it. It does the initial “clear the nozzle” feed just fine, prints just fine for the first 15 seconds or so - then stops extruding.
I’ve tried with both Cura and SnapMakerJS. Both result in the same problem.
It’s been power cycled several times as well.

Any Suggestions?

1 Like

Is the print head temperature staying constant?
At only 15 seconds, I assume it’s still on the first layer.

Yes, I haven’t noticed any variation. It happens every time.

What is your starting layer thickness and width percentage?

Initial Layer: 0.3mm, 110%

I checked calibration, and it was good.
So I reloaded the firmware firmware, and re-calibrated.
Problem still there.

I remembered have some weird problems some time ago, and what seemed to fix them was adding a brim to the part.
So I did.
That fixed it.
It REALLY shouldn’t have, but it did.

That’s pretty strange alright!

Have you tried uninstalling the software completly and reinstall them?
For cura maybe the start script is not working fine…
You can also try to set the temperature to the maximum the supplier states on the spool for checking if the extruder works fine, not if the print sticks well to the bed.

Just some additional ideas.

1 Like

Note that the problem happened with stl’s generated from both Cura and SnapmakerJS.

AND the cure failed. While it did actually print the part, the “brim” was more of a raft. This resulted in all the small sections that MUST be separate - being attached to each other. Impossible to separate without breaking them.

I spent a chunk of time examining the gcode.
Shortly after starting the print, it does a LONG sequence of moves with no extrude.
Both from Cura and from SnapMakerJS.
So, using Cura, I started checking all the possible settings, and finally found the issue.
In Travel, “Combining Mode” was “All”, so when it moved, it avoided all printed parts if at all possible.
This apparently includes “soon to be printed” parts.
This piece has a large spring in the middle, and the head was moving from the inside hub, to the outside hub, avoiding all the spring coils by traveling along the entire length of the coil.
So I set Combining Mode to “Off”, and turned on Z-Hop.
Now it’s printing fine (no brim), and the estimated print time dropped from over 10 hours, down to 4 1/2 hours.
As far as I can tell, this setting can’t be changed in SnapMakerJS.

No, the problem is not software related…
I’m glad you found the faulty setting.

I had a similar issue and replacing the nozzle resolved the issue for me.

There is a residue buildup inside the nozzle that varies on various grades of materials used.

The insulation in the feeder tube also tends to feed into the nozzle after extended use. Again replacing the nozzle solved my problem. I bought ptfe tubing and a pack of 0.4mm nozzles on Amazon and rebuild my spare stock as this occurs.