Dual Extuder - Left stopped working, but only in X

Just like the title says - my Left extruder stopped working, but only on the X-axis. Is there any kind of rational explanation for this?

I ran the X/Y offset three times now. First time I thought it was maybe an error on my part. 2nd time I figured something was up, but ran it a 3rd time to get a nice clean photo of the print to post, but I can’t upload a picture, which is very odd for a support forum. So close your eyes and imagine the X/Y-offset print, but the X-axis one is only a single color, while the Y-axis bars look fine.

Anyway, the left extruder loads and feeds manually just fine - even on the Y-axis offset test, everything looks the way it should. Not sure what the problem could be for an intermittent fault like this.

FW v1.18.20240116
Dual extruder (obv.)
Quick Swap kit
Air purifier

So I saw there was a v1.19 FW available and installed that and the problem went away. Which is all very bizarre, since the printer was working fine on v1.18.whatever last time I used it.

I guess, problem solved.