Dual Extruder Problems & Gripes Mega Thread

Does anyone know what this error means?

I mounted the dual extruder module and executed calibration.

I upgraded the firmware a few days ago. it won’t let me see anything right now it just wants to calibrate.

so i killed power and removed the connector to the module so i could see the firmware version.

Printer does not see any new firmware to install.

This could come from a false z offset by a custom bed platform or something else.
I had to mount the original platform and sheet, then it worked.

Thank you for responding.

I had reinstalled the original print sheet prior to running it because I didn’t have a way to do it on glass yet.

In my case, it ended up working the 2nd time so it was just a fluke.

I like this new calibration method it uses. I had to tune the Z offset in afterwards some. The second test print was not going well because it was too high.

It was really nice to see how the nozzles have their own mini Z axis and seemed to use the increased voltage/current from pressure against the motor to trigger the fact it was touching the surface. It makes me wonder if we couldnt forego the proximity sensor entirely with a little tinkering. Or is it really not doing that, and just using preset values and hoping for the best? That could be dangerous for glass.

I am running a spool holder for nozzle 2 right now. It am still trying to figure out how to deal with this properly. Its running well right now, but it didnt prime the 2nd nozzle as instructed, but it did move the nozzle off of the corner which I didn’t expect based on my start gcode.

The nozzle not in use tends to leak some and its leaving a bit of string here and there. I will have to add some retraction when tool changing or try one of those ooze shields.

I am waiting for firmware update because of bad pid regulation of the right extruder, so more testing about retraction with the right makes no sense to me.
Have fun :wink:

Oh we have a firmware issue? Is this the supposed heat creep i read about then?

I’m super rusty with the machine as it is, so I’m just diving in head first without much awareness of whats happening around me.

I definitely need to fiddle with ways to have the nozzles primed before printing, I was printing this thing

the dark orange is support. i didnt really need it but wanted to try it. it just made a lot of crumbs and mess everywhere

Yeah the head is hanging off the front of the bed on mine when it does that. Rebooting makes it go right back into the initial calibration routine and I get nowhere. It’s a loop I can’t get out of and I don’t know what the actual problem is. New actuators, new power supply, new dual extruder.

really? huh.

what i did, not sure it made a difference, was… powered the machine off and booted it with the module unplugged so i could see the firmware version. confirmed it was current. then powered off and plugged it back in.

it worked the next attempt.

hopefully that can help you

The main heatcreep problem, so guessed other users, was the disabled heatbreak fan at toolchange, this was solved in. 21 firmware.
The clogging/grinding problem still exists, maybe because of too much preasure on the filament on both extruders and additionally bad temperature regulation on the right extruder.
But nothing from @Riskey or suppport about this problems in the forum. - Any news are appreciated.

1 Like

Oh no, that probably means the dual extruder isnt going to be be printing flexible filaments very well…

i was seriously hoping to get better reaction on those… i was more interested in that than dual filament. they told me via email it was going to be a significant improvement.

Yeah, I think I’ve got bigger problems.

This morning I removed the dual extruder and installed the single back on.

As I said previously I had made several changes all at once, all new linear modules, new power supply, etc. Basically, like putting together an A350T that thinks it’s still an A350.

I normally don’t use Luban to connect directly through the COM port but I have done so in the past.

I downloaded Luban 4.7.2 on the laptop I would use to connect to the ‘workspace’ with a USB cable and wasn’t really surprised when Luban said it couldn’t identify my machine, and wanted me to pick what I was using from the dialog box.

I’m going to find the post that talks about doing a factory reset and start over.

When I’ve tried to do homing or start to do something like calibration the Y axis drives all the way back and then only stops when it runs out of travel, and then just makes a grinding noise for about 5 seconds (not pleasant). The X axis sometimes goes all the way to the side where the controller is and then runs out of travel and it makes the same noise. Z axis is the only one that doesn’t go all the way. Just shy of the top of the actuators by about 1/4 inch and stops.

None of this was discussed in the “Brief Guide” that came with the actuators. And I am running the latest firmware, having updated that before changing the actuators, and again afterward when things were obviously ‘going sideways’. I’m not really familiar with G code commands so I’ll have to do some research to find out what I should try next.

You sure you don’t have an assembly error then?
You have the linear modules in right places? They’re no longer interchangeable. Z should be marked Lead 08mm. X&Y 20mm. Everything in correct holes? Rails centered and not hanging off bed?

Not recognizing your machine is interesting. Make sure your firmware is up to date and run for each head from usb stick. With machine off unplug and reseat all cables.
Might want to try and do a factory reset.


So…it’s sorted now.

I had assembled the machine correctly. All cables attached properly to their respective positions.

When I connected to the machine with Luban and it said it didn’t recognize the device that was a clue to me that a total reset was needed.

I had already updated the firmware before the actuator changeover and addition of the dual extruder. I even updated again with the same firmware.

Turns out I needed to reselect the correct machine type and extruder type and then do the M502 and M500 and then after a reboot I got the whole calibration and setup for the new extruder running with no further issues with the linear modules slamming into the ends of their travel.

This should be part of the instructions for replacement of the newer linear actuators…a complete reset of the machine so that it doesn’t retain the old limits settings. Because obviously the controller didn’t recognize that the actuators had been changed.

1 Like

I have very frequently had luban not recongize my machine and having to re-assign the model etc.

Glad you got it worked out tho.

1 Like

Why did I buy this stupid thing…? What made me think it was going to work properly after all the nonsense I went through when I received it after waiting an eternity…

Already stopped printing on nozzle 2.

How much BS are we going to go thru to make the 2nd nozzle function properly?

So frustrating… I could have ordered a nice machine that can print flexible without problem that has a proper heated bed for what I paid for this dual extruding module.


It’s definitely different. Mine is working currently. What’s wrong with yours?

I bumped up my temps and that seemed to help. If it does get stuck, you often have to unload it to get rid of the section that was ground down by the direct drive. For the break away stuff I’m at 230/190 rest. For my pla plus that I used to print 200/150… I’m at 210/170. I always use a wipe towdd; you have to use auto supports and can’t do them manually. I had to change that to 18mm3.

And, im leaving the door open… something about heat creep. I dunno if it’s helping or if I finally got my z offset right between the two materials.

Its like preorder = Beta-Tester, this is the way snapmaker work since company start…
I read in the forum, others print the pva with 20° more and work fine.

I use only the left extruder to figure out, i changed the nozzle and can confirm the main problem comes from filament grinding by retraction. Not sure if it would help to lower the force on the gears.
I will check retraction settings tonight and maybe compare with luban.

1 Like

How are we supposed to correct such a flaw? Is that what this little plastic clip is for?

Too much grinding means TPU isn’t going to print very well. The primary reason I wanted the change is so that I could better print TPU. I have different springs I bought which help print SOME TPUs. However, most of them do not print well. The particularly soft one I want to use does not print at all on the old module, and many of them will feed with the lighter spring, but even with 70% increased flow, is still insufficient for the walls to fuse together in many cases. (Yes I have the little adaptor printed for that)

There is no way that snapmaker is going to be able to make this right with the grinding filament unless the gear is inside of the hotend assembly. They are not going to replace the modules… I still am using the crummy original linear modules because I don’t want to spend what is it 800 dollars on a new set? They did send me some extra modules from all the problem I was having after a few transactions of replacing bad ones, all of which I should install because they current ones are sloppy as can be and I just haven’t really wanted to deal with it.

I don’t mind to an extent that the product needs refinement via firmware, but hardware changes are not fair, particularly with the long history of ordeals we have patiently went through. Whatever they are going to do to address these module issues on the dual extruder better become available to us. It is just plain awful that after all we went through that they released this poorly functioning module. They have other new printers now, they should have learned their lesson by now.

Since others have been also chiming in with problems, I have revised the title of this thread. Maybe in our frustration and anger, Snapmaker will react and maybe we will end up working together to find solutions as we have with the rest of the machine.

I have not yet gotten a solid look at how the extruder operates. I have a little plastic clip I printed (2 pieces) that I am not yet sure what it is needed for. I am thinking maybe it was snapmakers solution to the excess pressure causing the grinding?

On the old 3dp module, I bought a bunch of different strength springs and have found that different springs work better for different TPU shore hardnesses. If this clip is infact for the pressure, maybe different clip thicknesses will have a similar result. If this is infact the case… I think maybe it would be best to come up with a set screw adjustment.

1 Like

To be fair, this is pretty par for the course… if you go to the bamboo forums you’ll see they’re not much different even though everyone touts them as ‘plug n play’.

TPU is a tough material to work with. I’ll try it next on a test print.

The frustration is mostly from the lack of transparency and action. Most of this could’ve been solved by sending out test units to experts in the community so that there was a good collection of data on the modules before they built them.

Go over to the J1 subforum… they’ve got real issues.

Dang. Got my dual extruder today and after reading some of the threads I don’t really feel like fucking around with it now. Took me a long while to get the original extruder working the way I want it.


I had alot of initial success. But yea, it definitely has some growing pains similar to the original.

Edit: today I decided to try and do some controlled tests. I took the same model (Nikko Industries Calibration Fox) and loaded the same filament (Polynomics PLA Plus - Blue) with the same settings. Single extruder at a time. The left printed better than the single extruder ever did for me. Detail was good; some ‘pulls’ where it retracted but left a string in like 2-3 spots, but overall a super clean print.

Right nozzle? Initial layers went down fine. After that it slowly went down hill. Both times it ended up with ‘bumps’ that ended up knocking the model off the sheet.

Anyways, super frustrating. @Jade What’s the plan? Can you fill everyone in on what’s going on and what SM is doing to fix it? Do you need beta testers? A little transparency would go a long way. It’s been 3 months and we’ve seen very little action to fix the major issues (half the module isn’t functional).