Custom Macro will not run

I am trying to create a custom macro in Luban v4.0.1 (following the bed leveling calibration forums) but every macro I create will not execute. The predefined macros appear to work just fine. As a test, I copied the M1007 macro contents and pasted it into a new custom macro:

But when I try to run the macro, nothing happens. When I edit the macro, the “Repeat” field is blank:

If I update the value to 1 again and save, the value is still not stored correctly. Instead, the value is 0 after this point. No amount of updating/saving a non-zero value seems to fix it.

I suspect the “repeat zero times” logic is what is preventing the macro from running and the actual bug is that Luban isn’t saving the repeat value correctly. Has anyone else experienced this?

hmm i do see if i tried to make a macro with that it wont execute. Or any other custom macros. Guess they should be told about this @staff

i didnt realize they added those macros to luban - the top one is dangerous :open_mouth:

Thanks for checking. I only noticed them today when I had my laptop connected via Serial. They don’t seem to appear when I am connected over Wifi…

that makes sense believe it or not.

the console is unable to give you information back from the machine over wifi, you can send commands but not receive info back.

my original post to you kinda went over that but i erased it when i tried to do the macro myself lol