Connect/Set-up Artisan to/with Cura


I´m new to the world of 3D printing. I tried the luban software but found that it is really bad. Temperatures are not handed to the machine and the printing quality is really bad. I want to try out cura as a 3D printing software but I am unsure how to connect it or set up the Artisan with/in Cura. Could someone provide me a “how-to” for dummies?
Many thanks in advance!

I set Cura up today for the Artisan.

Create a new machine with the following settings:

I also installed the cura plugin “printer setting” that i can set the “heat up speed”. Without this setting i got errors when the nozzles switches because they werent pre-heated.

;— Start G-code Begin —
M205 J0.05
M201 X100000 Y100000 Z100 E10000
M204 P1000 T2000 R10000
M900 T0 K0.035
M900 T1 K0.035
M104 S{material_print_temperature_layer_0} ;Set Hotend Temperature
M140 S{material_bed_temperature_layer_0} ;Set Bed Temperature
M109 S{material_print_temperature_layer_0}
M190 S{material_bed_temperature_layer_0}
M107 P1
G0 Z0.5 X0 Y-0.5 F6000
G92 E0
G0 X150 E30 F1200
G92 E0
G1 Z5 F6000
;— Start G-code End —

;— End G-code Begin —
M104 S0
M140 S0
G92 E0
G1 E-2 F3000 ;Retract the filament
G92 E0
G28 Z
G28 X0 Y0
;— End G-code End —

My Cura Profile for 0.2mm:

1 Like

What heat speed have you defined for both extruders?

but can certainly still be optimized.

Thanks! I will tey those settings then

You can also refer to the official github setting URL as follows:


Thank you so much! That helps really a lot.
I also tried calibration from but had the some issues there as I was not able to read the luban gcode in notepad++ (maybe because its marlin?). This resulted in the nozzle always scraching on the heat bed at the beginning of the print (must have something to do with the start gcode and the ABL safe or so). I made the heated bed calibration with a 9x9 pattern and the z-offset with a sheet of office paper. I will try the calibration again with the start gcode from above. Hopefully that reads the storage of the artisan so that the machine knows the calibrated z-ofstet and stored auto bed leveling.
Thank you so much again for the help!

This post saved me, I struggled so much with LUBAN and thought I just purchased a $3,000 pencil cup maker in the Artisan as that is all I could get to print. Followed this thread and total night and day difference with quality, and ease of use. Snapmaker should just focus on integration to other tools that do the job well. Lifesavers!

Hi. Which way did you choose? The one from the second post or with the plugin from GitHub?

I followed the simple drag and drop instructions from GITHUB link GitHub - Snapmaker/SnapmakerCuraPlugin: Snapmaker plugin for Cura 5

1 Like

I’m all in for Cura and have been using it for a long time.
I recently got a snap maker artisan and started using Luban… not that bad honestly. I wonder what is it that your facing trouble with?

Honestly when using LUBAN the machine seemed to forget all its calibration, extruding off the bed plate, making spaghetti on the bed, Not warming the bed temp to what was set in LUBAN. The only thing I could get to print is the preloaded Pencil Cup and even that was on the second try. Same file in Cura, no issues prints like a charm. I deleted LUBAN and reinstalled on my MAC, updated to 4.7 and running latest artisan firmware. I spent 9 hours of messing around in LUBAN going 1 for 7 on successful prints. CURA I was printing the same files from Thingiverse in less than an hour. The machine has been running non stop from Cura with no issues on any of the 3 different prints since Sunday. I have changed color and types of filament with no issues on Cura. I plan on learning the laser and CNC in LUBAN later this week. We will see if LUBAN continues to struggle.

Does Cura connect via wifi or not? I get can’t connect.Not a problem but would be nice.

I use Cura with the Artisan over WiFi and it works fine for me.

do the preview images work for you when a file is sent to the artisan with cura?

Installed the latest Snapmaker Cura Plugin (V0.7) from Github.

Not during file selection, only when printing is called up.

How do you do that? How do you connect cura to artisan over network?

Has anyone had any success getting Cura to print 3D to Artisan over wifi? I can get it to see the Artisan, though when I select send to [ip address], it gives me an upload dialog, the completes, then disappears and then nothing displays over the network.

Haven’t done this, but wanted to check if you actually looked for the transferred file in the console after it’s sent?
It could be a “send and receive” function, rather than a “send and print” one.

Yeah - first thing I did. There was no file there. I even deleted all my previous prints and sent again to confirm.