CNC ignoring jog height

Hi,
I’m using the CNC router to plunge holes into a circuit board. For some reason, it’s completely ignoring the jog height (and the plunge depth, for that matter). It should be plunging 2mm which will see it though the board (1.7mm). However, it’s only plunging 0.2-0.5mm (at a guess). it’s then coming up about half that (if I run a boundary before I start), it clears the board the entire way).

Interestingly, when I start the job, it jogs up the correct amount (I went with 1cm to make it obvious)… it then plunges the 1cm + depth… it then jogs around at high speed while still in the work piece (destroying my circuit tracks in the process).

Has anyone seen this behaviour before or have any idea why it wouldn’t be obeying it’s jog height, when it clearly seems to know it because of the way it starts?

This is with Luban 4.1.3 and firmware 1.14.1 (eg. latest at time of writing). 3D printing and laser seem to behave themselves, so it’s not a hardware issue.

Thoughts, ideas, suggestions welcome.

What does the preview of the gcode look like? You can see that in the workspace in Luban or in an online viewer like this one https://ncviewer.com/

Most likely something went wrong while creating the toolpaths

Yes, the toolpaths seem to be stuffed… but repeatable so in luban… each time I do it. Shows the plunges, but no jog height.

hi,

Same issue here with CNC on Luban 4.1.3

My Tool increases the height not at all in phases it should not carve.

Now I tried something different: since I am only engraving, I set the target depth to 1.1mm and tried to set the work origin to 1mm above the material. Like this it seems to work somehow

1 Like

Good Suggestion. Thanks.
Are you using an image for depth?

If the toolpaths don’t look good in the preview, the results won’t be better.

How are you generating the toolpaths? What options are you using?

Yes, the source is an image.

But now I encounter the problem of X/Y axis isn’t parallel to the surface :frowning:

Hi @Medio - it’s well known that the bed doesn’t sit level. Most people will use the waste board supplied (or cut one) and mill that flat. That will help, but won’t help with the tray itself leaning when pressure is applied. I make little “flat beds” for the size work I’m doing. Tedious, but it helps.

Between your suggestion and my thoughts, I found that using an image doesn’t seem to jog or offer any sort of clearance. I (labouriously) drew all the holes in luban (on top of the image), and then it worked correctly.

It didn’t seem to accept SVG either, and the annoying bit about drawing the holes in luban, is they end up being very small circles to trace rather than a single plunge… :frowning:

@brvdboss - I’m using an image, which seems to be the issue. Do you know any “tricks” for taking an image which should be single-point plunge (drill holes) and getting it to avoid the surface? Medio’s suggestion of setting the origin 1mm above the surface seems pretty good. But now I’m not sure what quality of holes it’s going to drill.

Unfortunately Luban isn’t the perfect software for this and lacks the necessary features to achieve this.

Importing SVG files should work though, although Luban is sometimes rather picky when it comes to exact file contents. It doesn’t always parse it correctly. (Opening and saving it in inkscape often fixes this problem). (and holes will need to be small circles indeed, you could compensate for that with the right size millingbit)

Specifically for PCB’s you could try flatcam (do a search on the forum). It’s software specifically for cnc-ing pcb’s, however it’s not the most intuitive piece of software and some things like “run boundary” don’t work with gcode files generated from it.

2 Likes

Thanks @brvdboss. I tried SVG and it didn’t like that either (I think the holes were too small, even a 1mm holes… they just didn’t appear. :frowning: I’ll see if inscape makes it happier!
Thanks for the suggestion of flatcam. Boundary runs are the least of my concerns!

I have the same issue I was using an old version with no issues. Since upgrading to 4.4.0 and using firmware 1.14.3, it also ignores the jog height.

My last two cnc’s always have a line through the image about .5 inches up that dig down really deep.

Yes, the preview looks perfect. There is something 100% wrong in the current version that causes the jog height to be ignored.

This has nothing to do with the plane of the wood or the bed level, it’s something in the software.

1 Like

@squirrel, thanks for the confirmation that it’s not just me. Have you had any luck with further updates working again? I haven’t managed to get back to that particular project/issue, so I don’t know if it’s fixed or not.

I am having the same issues with my A350 CNC head. If you can’t increase the jog height it will scratch or cut in places it shouldn’t making it unusable as even an ok CNC machine.

Is Snapmaker looking into this issue?

I’m having this same issue with image files. When looking into the gcode file it has G0 Z0.00 commands where it should contain the actual clearance. If I use a shape instead of an image and set the jog height to 2 mm, the gcode file contains G0 Z2.00 as expected.

For a workaround I made a search and replace for the file so all G0 Z0.00 lines are replaced with G0 Z2.00 and now the jog height is 2 mm.

Same bug in V4.13.0