Clogged, new nozzle

3rd degree burn cleaning with an e string.
Opened the lid and pulled the whole guitar string through,
flossing vigorously and tweezering the plastic out.

Loading filament would run, but would clog up again within moments.
PETG - tried at 235 and 250.

Is this a nozzle issue?

If so, can someone recommend some fancy pants — unlikely to clog — 0.4 and 0.6 nozzles that will work with the SnapMaker 2.0?

What else might I try.
I don’t have nylon for a cold push though I can order some if need be.

The Snapmaker2 uses standard MK8 nozzles. Most people just use either the ones shipped with the machine or cheap replacements off Amazon/ebay/aliexpress unless they’re printing abrasive filament.

The real issue here is more likely to be the filament and/or the initial position of the print head. What brand of PETG are you using? Is there enough space between the print head and the bed when you start a print for plastic to squeeze out?

It’s the blue Snap Maker petg.

Hitting ‘Load’ at 235 the filament will come out.
It burbles and pops though; weak in places.

Running G1 E100 F050
barely anything comes out.

Sometimes it seems to bottle up and then come pouring out quickly.

More guitar stringing today.
Also tried ‘cold push’ with PETG at 180.
It comes through, but doesn’t improve anything.

Not getting to the bed part yet.
Just trying to get e-steps calibrated for the PETG.

Switching back to pla doesn’t help either.

Did you try a different hotend? Maybe the heating element/thermostat is bad. I doubt it’s a “bad nozzle”.

It also could be a problem with the ptfe liner inside the heat break. They deteriorate.

180 is way too low for petg. Be surprised if you could get anything coming out at that temp.
Some petg filament I print at 245.

If the filament is too wet you can get problems with inconsistent flow.

But I do agree with @snapUser and feel like it’s a hot end/thermistor problem and not reaching temp it’s supposed to.


How can I test the hot end aspect.

I only loaded at 180 later, as a cold-pull-esque attempt to clear it. I was trying all sort of temperatures between 235-250, none seemed to fix the calibration issue.

What would the ptfe liner inside the heat break involve?
I’ve only been using this for about 2 months, < 60 prints.

Hoping to get back up and running but I’m not sure what I need.

Have you tried swapping out the hot end?
It should have come with a spare.

Also might want to check that all the wires/pins in the connector are seated properly.

Ok, new hotend,
more or less same issue

‘load’ filament comes out, although likes to curl.

Running the e-step command code:

If I run it right after ‘load’
I get a drizzle and and then it stops.

Running against and it’s bottled up.

Any ideas?

I guess I should order a SnapMaker PLA and see if anything works in easy mode.

Any ideas… don’t take this the wrong way, but quit messing around with it.

So I have to ask…have you EVER printed anything successfully? Did you print a test sample right out of the box using the supplied PLA? I don’t think messing with different filaments and e-steps is wise until you’re very familiar with the printer. Only reason to start adjusting e-steps is if you have some sort of print quality issue. If you’re getting clogs and dribbles, there is NO WAY adjusting e-steps is even possible. Maybe the extruded gear is gummed up, did you check and/or clean it? I mean 3D printing isn’t rocket science… basically you squeeze melted plastic out a hole.

IMO, sounds like you’ve got things pretty messed up, and would be wise to do a full RESET.


So I’ve been printing for about 2 months ~~ 100 parts.

It started getting funky recently and now I’m trying to get back to where I was.
In the past I had no issue setting e-steps.

Why would G1 E100 F050 stop working?

I will try a full reset tomorrow.

Did you check the extruder gear? Maybe the teeth are worn or plugged up.

It sounds like your filament has gone off, after being exposed to some humidity. You could try baking it.

My brand new SnapMaker 2.0 used to clog a lot. Then I noticed the feed hole at the top did not line up with the feeder mechanism. I removed the two screws holding the round hole liner at the top, flipped it over, and just let it float in position (no screws). This fixed my frequent clogging issue. Perhaps this is also worth trying.

Back to SnapMaker black PLA helped.

Print quality wise - default settings are
much slower in Luban than Cura.
Getting better prints in Luban at the moment.
(moved to Cura because I needed “horizontal expansion” for a tight part.)

The nozzle is clicking over the support structure though, which sometimes dislodges either the bed attachment or knocks off supports.

Going to test the e-steps calibration again today, in between prints.