Changes to Z-Offset Not Always Remembered (was "Sticky Z Offset setting for 3D printing")

I’m obviously missing something simple here. Recently when selecting a file to print I had to adjust the Z-Offset for the file from 0.00mm to -0.05mm due to the particular filament I was using for that print (I left-swiped during printing to adjust the Z-Offset). This was the first time I ever had to fiddle with the Z-Offset manually while printing. Until this I always left it at 0.00mm.

Now, ever since I did this, every file I want to print defaults to -0.05mm Z-offset and now I have to go in and manually adjust every file back to 0.00mm. This persists even after cycling power This is a pain! I don’t want to re-calibrate the bed because it’s in a very happy place right now and I don’t want to lose that; I just want to get the default Z-Offset back to 0.00mm. I am running the latest firmware (1.10.1/20200822).

Thanks for any help. This is probably something really simple to fix but I can’t find it.

I have an update on this. I printed the same file multiple times, adjusting the Z Offset each time.
Setting Z-Offset to +0.10mm, printer “remembered” this setting next print.
Changing Z-Offset to 0.00mm, printer “remembered” this setting next print.
Changing Z-Offset to -0.05mm, printer “remembered” this setting next print.
Changing Z-Offset to 0.00mm, printer DID NOT “remember” this and defaulted to -0.05mm.

In order for the printer to “un-stick” the -0.05mm Z-Offset I need to change it to a positive number, do a print, then I can change it back to 0.00mm. This is a repeatable and consistant issue. I’d definitely call it a bug with the firmware.

Looks like a intentional part of firmware 1.0.9

  • Refactored the code for Z-Offset
    • Now the Z-Offset will be reset when you re-calibrate in 3D printing.
    • Z-Offset will be memorized even after machine reboots.
    • Z-Offset movement distances will be limited to -0.5mm ~ +2.0mm. We recommend you re-calibrate the machine if the Z-Offset isn’t ideal.
    • You can check for or change the Z-Offset value before starting your print on the preview page or the print page. (Swipe left to access the settings).

I have no problem with the Z-Offset being memorized–it’s a nice feature. My point is that the Z-Offset clearly is not always memorized in my tests and gets “stuck” on a previous value even though I repeatedly override it. That’s the issue I am having.

I could see why they might have it never memorize the - value and default to zero. That could keep you from having problems. You’re not going to cause damage with a + value. You might with a negative.
But that’s not what it’s doing.

You’ve got it a bit backwards: I set it to -0.05mm for a print and it remembered it. Then I tried to change it to 0.00mm but it DID NOT remember 0.00mm after the print and stayed at -0.05mm. I had to change it to a positive number, do a print, THEN set it to 0.00mm and THEN it remembered 0.00mm and stayed there. It’s a weird little bug.

That’s what i said. It’s not doing what might make sense. Its a bug.

I am new to 3D printing and just got snapmaker 2. Does that mean I don’t have to calibrate everytime I turn on the printer? Anyone can’t get auto-calibration to work well? Am I the only one? I figured the proximity sensor doesn’t work on mine…

The auto-calibration feature works well for me. You have to make sure that on that final point that you have to do manually you have the nozzle close enough to make the calibration card tough to slide in between it and the build plate. After that all you should ever need to do is fiddle with the Z-Offset. I never had to fiddle with it until I got some difficult-to-work-with filament that was not sticking well.

Does auto calibration works on glass? I found out I like glass much better than the original build plate.

You should only have to re-calibrate when changing beds. (btw, Highly recommended to calibrate with a heated bed.)

The sensor is magnetic so it doesn’t work with glass. For that you have to calibrate manually.