Calibration Issues after firmware update

So after some suggestions, been banging my head against the wall for the last day trying to get this sorted.

Since doing the 12.3.2 (i think, the latest one) update 2 days ago, i cannot for the life of me, get the calibration right, prints are either too high and don’t, too low and don’t stick (drag) or too low that they virtually meld into the print bed.

I did have it working the first day, although a little high, but after a few prints, the calibration seemed to go off and nothing would stick.

I have tried using the paper method for setting the offset as well as feeler gauges ranging from 0.05 to 0.13, but can’t seem to find the happy middle,

Any thoughts? or anyone else with a similar issue


Work towards finding something repeatable.

With the given description of the first layer prints are too high from the bed, and too close to the bed, and prints stick, and prints also don’t stick, this sounds like a calibration problem.

Use G42 to go to each mesh coordinate and lower the head down slowly towards 0 and verify there’s the appropriate tension at each point. If there’s not then your bed calibration is bad and you won’t get good first layers.

A typical series of commands might look something like this

G0  Z10 F3000 ; Go to near the bed without risking hitting it, at 3000mm/min
G42 I0 J0     ; Move to the first calibration measurement point
    ; At this point slowly jog the toolhead close to the bed, check
    ; proper tension on calibration card or paper or whatever you use.
G0  Z10       ; Raise Z
G42 I1 J0     ; Check next point
    ; and so on...

how? i assume, i need to plug in via serial cable and use a laptop?

Also in relation to the offset is -x closer to the bed or further away? as in if i set the offset -0.5, will that mean the print head is closer or further?

Print a skirt and manually adjust the z offset as it prints the skirt. I usually do 2-3 lines; around whatever object I’m making if I need to do a new calibration.

The autocalibration plus paper gets you close; you need to adjust it on the fly.

even with all the issues i have had with wobbling rails etc i have never had to do this to get good first layers

i would posit you have some issue with your machine you are working around but might want to find root cause (or keep working around it, i get some people are fine doing that too :slight_smile: )

try doing a full manual calibration and see if that helps

you might consider doing this test after bed levelling head is not consistent height when jogged - YouTube - hey i have a hammer so everything looks like a nail to me ¯(°_o)/¯ to see if you are hitting the same weirdness (support managed to reproduce this oddness on their unit and are investigating).

also you don’t mention what build surface you have, material, anything you are applying to the surface - if you have been using IPA to clean the bed, stop doing that and go wash the plate well with soapy water to remove the oils (IPA doesn’t remove it, it mostly just moves the crap around the bed).

1 Like

I think he means do ths adjustment on the first print after fully dial in the Z offset (which then gets saved until the next calibration).

I’ve used this method, it works, but as mentioned elsewhere I try not to use the live-Z-offset change feature except for temporary tweaks, e.g. testing squish on a new filament.

1 Like

ok, some further updates on this (been away for a week).

I tried the manual calibration, as well as upping my calibration points to the max (15 i think) - still having issues.

I also seem to be getting inconsistency between calibrations, for the sake of trying some, i used a 1mm feeler gauge to set the zero point, counted exactly how many mm’s, well 0.0x mm til the nozzle touched the gauge, noted down the home positions, then re calibrated 3 more times with the exact same settings, and tension on the gauge, but my z height was different each time, in the order of 0.05-0.1mm.

I have made things work by seeing the nozzle too close to the bed, (filament is translucent) this is at least allowing my prints to work, although makes them hard to remove from bed and leaves a mark (not an indent) on the print mat.

To answer and clarify some of the responses.

  • using standard snapmaker build plate, plus bought a brand new one to try.
  • cleaned and washed the bed with both IPA and soapy water
  • i am against having to manually adjust the first layer, to get prints to stick each time, i never had to in the past and i shouldn’t now, that is the point of the calibration - for fine tuning happy to adjust, but not for actual basic functionality.

I have some laser projects under way at the moment, so will revisit later. Although will most likely drop back to older firmware (if possible) the wireless issues is irrelevant to my needs,

Although thanks for the suggestions, there were some things i hadn’t though of trying - or knew i could do

I’m having this exact same problem. I upgraded the firmware and now when it calibrates it stops 1/4" from the bed.

I thought I was the only one having this issue. Normal calibration will squeeze the filament almost completely flat on the table and sometimes is too high, filament won’t stick, sent message to them about it but no answer yet. I do the calibration then print and wait for the outline of the print shows, when needed then go into the file’s settings and adjust accordingly. I feel that is becoming a real issue to the point of being unusable, hope we all find the solution to this problem.

in the end i was able to get mine to print consistently, but IMO it is printing too close to the bed, and flattening and turning filament transparent in some places. but i gave up, and just live with it. Prints still come off the mat cleanly and without leaving marks on the build plate, but i have to reduce the initial few layers down to 80% width to counter the elephants foot

Well, I was able to print doing a manual calibration. But after the print was done I did a automatic calibration and it calibrates it still 1/4" above the plate. I’m going to mess with the sensor when I get a chance. This is frustrating. I’ve been using it for a little over a year now with no problems and then out of the blue this happens.

I have had the same issue after upgrading the firmware to the latest one. It worked fine for almost a year with the original firmware, but I wanted the support for change filament gcode… Now seriously considering downgrading it back. Or throwing the machine away.

They changed the frimware to save the modified z-offset to eprom, so it could be remembered and applied in case of a power failure. Which is fine as such, but now there is no way to reset it.

To make things worse, there is some instance somewhere (read: bug), where it either ignores the saved z-offset or compensates for it twice, causing a mismatch between the actual measurement and what is saved. This mismatch can then grow over time.

What is totally catastrophic, is that automatic calibration does NOT reset the offset and fix the mismatch. At one point it started printing over a half millimetre too high (the plastic not even reaching the bed) directly after calibration. I calibrated twice, just to be sure, same result. And then I ran to the z-offset limit where the nozzle couldn’t be lowered any more, while it still printed in the air directly after calibration!

After fiddling around in frustration I somehow managed to cheat the machine. I can’t remember what I did exaclty, but I started a temporary print, and think I adjusted the offset in the other direction to get more room for adjustment and then stopped and recalibrated. Whatever I did, I did in small steps to avoid hitting the nozzle into the bed, and I got it to a point where it is close enough, and then let it be.

I have a suspicion, but because I don’t want to get it messed up again, i’m not gonna touch it. And considering that this was not a cheap machine, I expect it to be fully functional without me acting as a beta tester. I have had to help out quite a lot with boring software testing in work and even if I got paid quite nicely I still hated it. I’m not going to do it for free in my freetime…

But if someone else has the time and will to troubleshoot the cause of the issue, my suspicion is this: there may be a difference in how it acts, depending on whether you adjust the offset from the “adjust” button before starting the print or if you adjust the offset on the fly after the printing has started (by swiping the screen and then adjusting the value). Changing between PETG and other plastics I still may have to up the nozzle by 0,05 mm for PETG. But now I have only done it on-the-fly if needed during the printing of the skirt and the offset has not crept away in a while.

I hope Snapmaker really tries to find the cause of the issue or revert back to functioning code. After all, we can live with a print that ignores a modified offset in case of a rare power failure, rather than regular frustration trying to get the bed calibrated.

Or add a setting to choose which behavior you want (old or new). In my country we very rarely have power outages, and in the few cases we do have, they are due to exceptional weather which you know in advance. I can always postpone a large print job that relies on a modifided -offsets if they forecast an exceptional storm, but I cannot constantly waste hours trying to get the damned machine calibrated every time I change nozzle or filament.

I reported the issue a couple months ago, but they haven’t done anything to fix it. Here is the issue that I filed on GitHub:

Sep 2? That’s two and a half months ago. Almost a quarter of a year with this being messed up!

Thanks for posting your link. I’ll test your workaround the next time I need to calibrate. If it works, I can live with that. For the time being I have avoided nozzle changes or anthing else requiring a recalibration, meaning I haven’t used the machine much.