Camera capture goes wrong

Hi there,

what is wrong here ?

my files always seem to appear in the upper right kwadrant, and my camera capture does the same !

This is normal, the work origin for the SM2.0 is on the front left corner of the bed. This means that the top right quadrant you see your files appearing is actually a representation of your bed.

The problem I have with this is that if you send the file over WiFi to the machine, the work origin is set to the centre of the bed rather than the front left corner. This means that before printing each file it is necessary to reset the origin - tedious.

If that is so then why present 4 kwadrants? why not just one ?

1 Like

I dont personally use the camera method for aligning work origin. I believe manual setting of the work origin to be more reliable and accurate.

The reason for the multiple quadrants shown is precisely for said manual calibration. Sometimes you may place the origin ontop of a specific feature such as a pre-drilled hole for example that already exists on the material you wish to laser/CNC. This feature may be in the centre of your piece of material and so you would need to engrave/mill in the -ve X and Y directions as well as +ve therefore you require all 4 quadrants.

That’s fine but if you are using the camera then it makes no sense that the origins of the design and the machine are not the same automatically, this could so easily be fixed.

@Albutch Not only tedious, but damn near impossible to get right. I thought “OK, I’ll play the game” and put the text to be engraved over the camera image in the top right quadrant of the screen, only to have the laser head take off to the rear right corner of the bed when it should be going to the centre.

Except it isn’t. When you select “go to work origin” in Luban over WiFi, the head goes to the centre of the bed.

Yes the camera alignment isnt a great method as it stands. I had evaluated it as such months ago when I first got my machine which is why I always manually set the work origin and bypass using the camera entirely.

I just dont have faith that the stitched images from the camera will be accurate enough to ensure proper positioning. Whereas when I set the origin manually I never have any issues and the laser always works in the area I expect it to.

The tutorial video of camera capture may help https://youtu.be/cult_7nTTpk

I though that “work Origen” is the place where you decide it is ??
isn’t “home” is the upper most left position (X=0.0 Z=0.0 Y=0.0) ??

Hi Christian. Are you able to describe how you set the origin manually? I assume you use the laser to mark a reference, or something.

If you carry out manual job alignment i.e. not using the camera you simply prepare your model in luban with respect to the origin point (0,0). Once your file is uploaded to the Snapmaker and you begin the job , you will be asked to input the material thickness and the laser will move down near the surface of your material. Once it is near the surface the laser will come on to display the point it is directly over (this is your 0,0 origin point in luban). I then simply move the laser over to where I wish to start the job.

For example for engraving onto circular coasters, I centre the image/text to be engraved over the origin point. I then align the laser to the centre point on the coaster and save that as the work origin.

for cutting things out of plywood generally I align everything such the the bottom left corner starts at the work origin (therefore everything is cut/engraved forward and to the right of the work origin) and place the laser point on the bottom left corner of my plywood material.

Hopefull that makes sense!

1 Like

Awesome! Yep, makes perfect sense. Thanks for that description, I’ll give it a try.

I have the same issue.
But I have a SM original. So there is no camera and no WiFi.
How can I reset the origin to match the printing bed. (125mmx125mm).

It’s super annoying, to have the model always appear in the top right quadrant. When only the top right quadrant is useable space.

Luban “knows” I’m using the SM original settings so why this weird setting. Wasting 3/4 of my usable screen. Come on. Please. Surely this is an easy fix in the software.

Right click when zoomed and drag the top right quadrant to fill your screen.

Hold down Ctrl and drag the top corner down.