Bed Drift in 3D Print mode (have i bought a Lemon?)

This is my second post, Again as I’m brand new please forgive it’s been mentioned before.
I’m becoming totally disillusioned with this machine, I’ve spent so many hours trying with this machine I’m pulling my hair out. so much so I’ll take a hit and send it back, (best doing that than throwing it against a wall!!). Since the get go I’ve had problems with this machine, so much so, I’ve yet to successfully produce my first print (though not for lack of trying)… Can Anyone help me please?
My prints will start(I’m printing a test print) but as it gets to the first corner 4->3 and moves to the second corner 3->2 the filament hasn’t stuck at point 3 so drags the filament to point 2. from point 2->1 and 1->4 the filament sticks, repeat cycle, repeat, repeat, until i cancel.
I have discovered two things :-

  1. using a laser temperature gauge corner 3 is approx. 3-5 degrees cooler than the rest of the bed
  2. I level the bed, press save, return home, jog the print head. when i return to homing and then calibrate again the bed settings are way off in either direction (upto 0.5mmeither way). I will recalibrate again press save, and the process repeats itself.
    I’ve stripped the machine down, rebuilt over three times checking that I’ve not done something wrong in the building process
    I’m at my wits end! am i doing something wrong? Can anyone please take the time out of their busy day to help me?

I can hear your frustration from the other side of the world! Take a breath. There are lots of variables and you need to address each one before you’ll come out the other end.

While 3D printer manufacturers will have you believe that this is point and click, the reality is that this is a complex manufacturing process and you’re attempting to do this from scratch art home. So before you chuck in the towel take a step back.

To make this work, the device itself needs to be calibrated. After that each filament needs to be tested and adjustment made for its specific characteristics.

On top of all that, the model, the slicer, the settings, even subtleties like a draft running across your print will cause different outcomes.

I don’t know where in that journey you are. I don’t know if you have already done all this or if you have a faulty device or anything else that’s going on.

Give us some outline about what you’ve done so far, what the output looks like, what settings you used, what materials, what model, etc.

After that people on this forum will have a much better chance of giving you specific advice.

Hang in there. From my observation of this community, we have your back!

Deep Breaths, Deep Breaths,
Thanks for your quick response and great message, and sorry for my late reply. I’ve been outside chopping stuff away in my garden (rather that than the machine).
Yes you’re right, I need to take a step back!! I’m a fully qualified Mechanical engineer (Fitter), 30yr Firefighter, I have taught lessons to year 2 & 6 and to 14/15/16/17yr olds and none of that has had me more frustrated than the last 30 hours (actual Time spent over 3 days) than this Blooming thing!!!
I thought i had calibrated the Snapmaker V1, but every time I come back to it (It’s in the same place) even after I’ve saved the settings I have to calibrate it again, as the settings are completely skew with.
I have tried 3 different filaments one from that came with the printer and two different makes bought this week. all are 1.75mm PLA (different colours). I’ve placed the printer as far away from any door or window also it’s in a specified Snapmaker Enclosure,( I bought the complete package). I’m not sure about the slicer (or if I’ve even got one).
The models I’ve tried to print are from the Snapmaker site (for the first 10 hours), and then from a website, I’ve made sure that they are compatable for V1 and have no problem Generating a G code ( the machine has always recognised them) they have been printer test pieces and i have used the recommended settings apart from ( after testing the bed with a laser thermometer) I have gone into custom, and raised both the bed heat and printing heat by increments of 1 degree upto 7*c above recommended.
The results have mostly all been the same with me having to cancel printing within 5 minutes into the printing process as the filament is lifting or being dragged around or the nozzle is just pumping out plastic around the nozzle( I’ve checked the latter and the bed has dropped to over 10 paper thickness).
Any help would be gratefully appreciated, I’m sure I’ve done the levelling process correctly and saved the settings correctly, I’m 100% sure that all bolts are secure nothing moves on any of the frame, and I’ve dismantled and rebuilt using different modules in the X,Y,Z axis.
Like I’ve mentioned I’m a complete novice, I could be doing something blatantly obviously wrong.
Many thanks for reading this, I hope I’ve mentioned enough for you to grasp if I’m doing something wrong.

Sorry if I’m not full digesting everything you’ve said. Sounds like your biggest issues are bed level and machine calibration.

Regarding bed level, if the auto calibration isn’t working you might be able to manually tweak the mesh. I don’t have a V1, but on the V2 an M420 V outputs the mesh data, and M421 allows you to edit individual points by raising or lowering them a small amount. G42 allows to you go to a mesh coordinate, and then if it’s too high or low you can adjust with M421.

Regarding the rest of the calibration, go through the checks here: Some of them aren’t applicable, like the frame check, PID autotune and drive current. But the baseline print, e steps, flow calibration, retraction, temp, acceleration, and linear advance you should all do.

Hi again Brent,
Again, thanks for your response.Also sorry for my late reply, I decided to walk away from 3D printing for the day and try the laser cutting, which I had some success.
Unfortunately I have a V1(original) and all it has is a manual level. You start at point 1 (rear left) and work your way round clockwise. Then after setting the 4 points you save your adjustments, that’s it I’m afraid.
I have started looking reading/watching the vids at the webpage you gave me, Thank you.
As I stated before, I’ve tried every module in every combination, but I haven’t checked the grub screws on the threads (I’ll do that today). But with my success at laser printing, albeit only photos, I am tending to think it’s either human error or failure of some part. I’m going to find out in the next few days.
Once again, thanks for your help and taking time to write me, really appreciated.
Kind regards