Bad print quality only in low z coordinates

Hi all, hope someone can help me. I’ve been having trouble with every print where the first layers have very poor quality, seems like some overextrusion. The first 3-4 layers at 0.16mm seem ok, then 5 or so layers are terrible and then everything is good untill the end. This was printed in Luban with default Normal quality settings with standard black Snapmaker PLA 1.75mm at 205°C, bed at 70°C initially cooling to 50°C. Does anybody have any idea what could be causing this? Improper z calibration? I’m starting to fear that there is a region in my Z modules where they don’t move enough upwards, causing the nozzle to press into the layer below. I have receiver my printer last week and have only done some 3D printing so far, yet all my prints come out with this bad section, regardless of the object being printed.

Things I have tried so far without success:

  • different slicers, Cura, Prusaslicer, Luban: all the same results
  • changing nozzle z-offset: improved the elephant’s foot so first couple of layers were better, but at like layer 5 it started degrading. These are the pictures where I only printed the bottom of the cube.
  • lowering bed temperature from 70 to 50. Didn’t change anything.
  • printing at 0.08mm layer height instead of 0.16. This was to verify if it happened at a certain layer or at a certain Z-height. Appears to be at the same Z-height.
  • E calibration: changed S212ish to S245ish. Didn’t solve anything.
  • Motor step calibration. Didn’t solve anything.
  • Printing the cube with 100% infill. Exact same problem.
  • Printing with heated bed off. Nope.
  • Printing the same object on top of the previous one in 2 seperate runs (same gcode but obviously with a z offset in the second run) made the 2nd object look flawless, which makes me think it might be a linear module fail at a certain region.

Things yet to try:

  • printing at < 205°C
  • swapping y and z modules to see if issue exists in y modules as well
  • checking z modules for mechanical issue in that region? I’d like to keep this as a last resort as to not void my warranty.

Picture of a complete calibration cube and below that one the start of a new one with some changes, but with the same result at the same height.

1 Like

Additional picture comparing 0.16 and 0.08mm since I’m only allowed 1 attachment per post as a new user.

The consistency of the failure definitely looks like a linear rail problem.

A (painful) idea you could try: disassemble the machine and swap the z rails to be the y rails. Since you won’t often be printing at the far front of the bed, it’ll be easier to avoid the problem area while waiting for support to get back to you. It’d also help to verify your (imo, probably accurate) assessment of the problem.

1 Like

Thank you for your reply Kevin. I have added some things I have tried in the meantime my original post, but without any success. It is indeed dawning on me that it’s probably a mechanical issue in the z-rails. I have contacted support and while waiting for their response I’ll disassemble and reassemble the machine with the modules swapped… once I find the energy to go through it again :wink:

Hi Poedelie,
I have the same problem, I attachment a pictures of the printed item, the file STL and the gcode generate by the software Luba 4.0.3.

Have somesone resolved this kind of problem?

test_cubo.gcode (161.3 KB)
cubo_test.STL (39.3 KB)

HI Kiuv, sorry to get back to you so late.
I ended up contacting support who suggested that I swapped the 2 Y-rails with the 2 Z-rails. This solved the issue which pointed to a mechanical issue in the lower end of the (previously Z) rails. They then told me to how to tighten/loosen the rails so that the problem won’t occur on the outer edge (now Y-rails) of the bed.

Did you request (demand) replacement rails?
Because while swapping out is a fine workaround to get you going, it’s not acceptable that there’s a known mechanical issue with your rails.

This was my first interpretation as well, however they assured me it was just a matter of properly loosening/tightening the insides of the rail with the following steps. I will copy-paste their instructions.

In that case, the Z-axis seems to have an issue.
Please turn off the machine and remove the X-axis from the Z-axis.
Then hand-push both the Z-axis linear module’s carriage from the top to the motor end.
See if the friction is bigger when closing to the motor end.

If the frictions of the two linear modules are the same, then please refer to the below instruction to check and to see if they have different moving distances.
The instruction is for the Y-axis, just treat it as the Z-axis.

  • Dismantle the heated bed, platform from the Y axes so that we can see the movement of sliders.
  • Power off the machine, push the sliders to the foremost end of the linear modules, and make sure they are at the same level. Place the laser work platform across the two sliders, making sure they are on the same level.
  • Here is a video for your reference:
    Linear_module_movement.mp4 - Google Drive
  • Then power on the machine and click “Home” on the touchscreen. Please check if the sliders remain at the same level as the laser platform.
  • And then you can control the sliders via the touchscreen. Make the two sliders 200 mm lower and check if they remain at the same level as the laser work platform.
  • After that, swap one of the Y-axis linear modules with the X-axis one. Then run the same test.
  • Choose those two that have the closest moving distance as the Y-axis.

I did have one axis that had a different friction near the bottom as illustrated here.

There should not be any friction like the left one.
But you can fix it by adjusting the motor end screws.

  1. Loose the four screws of the motor end (the end with the cable) a little bit. (Don’t remove the screws)
  2. Handpush the carriage to the motor end. (You should realize that the friction is gone)
  3. Tighten the screws and push the carriage back and forth to check.

I ended up testing all my rails and adjusted 2 that had some sort of friction.

This is hilarious to me.

1 Like

All the rails should act and work identically out of the box. Anything else is bullshit and trying to make up for unacceptable quality control. For a while last year they had a batch of rails with different lead screw tolerances/travel/dimensions and their ‘solution’ was to figure out which ones matched up most closely. :roll_eyes:

If a little adjustment was needed and their solution fixed the problem (all rails behave the same now), then that’s fine. If their solution was to put the problematic rails where the problem would only appear at the extremes (but still within normal working dimensions) that would not be okay. In that case I would demand replacements for whichever rails are affected.


1 Like