40W laser module + LIghtburn

Hi,

I recently received my 40W laser module, tested it with Luban at is working fine.

When trying to use with Lightburn (with the same setting that was working fine with the 1.6W module) , it keeps going to the bottom left corner and never work in the work area/piece.

Kindly assist with setting I need to adjust in Lightburn

Don’t have the 40W module, but I would assume the info from the wiki should be a good starting point to have it set up:
https://wiki.snapmaker.com/t/lightburn

Thanks, 1st step at least, I got the setting files, but still not working properly, I do not know why the machine keeps going to the most left side and start operating in the same location

OK, I downloaded the (snapmaker-2.0-40v1.lbdev) file from Using Ray / Artisan / 2.0 with LightBurn | Snapmaker Wiki and imported into Lightburn.

Still only cutting and lines tasks are OK. But any engraving task is a total failure.
I checked the Gcode, the difference is that for engraving, Lightburn use relative positioning with code G91, while Luban use absolute positioning withing G90 code.

Was anyone successful in engraving (not cutting) with Lightburn and 40W laser module ?

Yes. I have engraving white laminated MDF 3mm. And after engraving I have cutting it to make a box.

I’m not at home now. I don’t have the settings and files on these computer.

I’m at home Saturday. I post my settings and a file.

1 Like

I don’t use lightburn but what is the nature of the failure; nothing or overburn?

Just an idea, go into luban (I know your aren’t using it but humor me). Change it to workpiece and center. Then go back to light burn ( I don’t have light burn but I’m computer techy and have seen native programming still have an effect on a machine even when the native program isn’t being used). If light burn has these type settings also, be sure they are the same when creating your gcode

Lightburn has much more settings then Luban. If the settings are correct, it works without any problem.

My first thought is that youssef use user position and not absolute coordinates.

1 Like

I haven’t delved into lightburn as I just started out. I’m installing my 40w tomorrow and hoping for good results

I have used “Absolute Coords”.

But still Lightburn for engraving layers, issue the code using G91 code (Relative coordinates), and for line layers, issue that part of the code using G90 (absolute coordinates)

I attached photos for my current setting as well as the Gcode generated file.



003

40W laser test.nc (216.3 KB)


This is the box I have made with the 40W laser and lightburn.

I use this settings
Snapmaker_40W_Marlin_quick_swap.zip (2.7 KB)
Take attention that the height in the file is based on the quick snap kit. The original file is here to find.

; 40W Laser - Example value only for orientation, use at own risc!!!
G0 Z96.8 F6000

This is the file I use to laser.
Snapmaker_forum_01.zip (62.3 KB)
The Gcode.
Snapmaker_forum_01_gcode.zip (21.5 KB)
Settings