10w Laser Won't Power On for Shapes Without Curves

Strangest thing.Luban 4.9.0 Firmware 2.5.16. New machine. I tried to print the test pattern (compass, square) but the square outline cut failed. The compass cut fine, but when it got to the outline cut for the right square the laser didn’t power on even though the control unit said it should be at 100%.

Initially I feared the laser failed, but after several simple tests I’ve come to the conclusion that it will cut any shape with curves, but no shape that consists of only straight lines. I can’t cut a line, a square, a rectangle, nothing. It must be a software issue.

Anyone else see this?

1 Like

It’s seems like it’s all related to the update, please fill out the ticket Support Ticket Form

Having exactly the same issue. Tried deleting all other paths and re-running the ruler outline… the laser happily passed around the perimeter displaying 100% power while shut off.

1 Like

I reverted Luban to 4.8.2, kept the new firmware (which apparently has working inline power control) and now it works properly. I just cut a variety of squared and curved shaped, then etched grayscale imaged into basswood using both line-fill and dot-fill and everything looks good.

Bottom line, Luban 4.9.0 is hopelessly broken for laser cutting / engraving.

PS for SM support. I’m not wasting time filling out a ticket since there doesn’t appear to be anything wrong with my machine, just Luban as reported by several users across multiple online forums. All they need to do is read Skreelink’s analysis of the code where he calls out the bug.

Hi @Fishstyx ,

Thanks for the report. We have detected this issue and fix this soon in the next firmware update. @nweolu Thanks for drawing my attention here too. :smiling_face:

Hi all, thank you for pointing out the problems. Please check out the update on Luban V4.9.0 issues here:

1 Like