10w and Rotary Setup Issues

I’ve been engraving with the laser bed and 10w module for a few weeks now and just recently tried to add the rotary module. I swapped the bed to the cnc platform and attached the rotary module and upon powering up, there wasn’t an initial setup or firmware update prompt like most other modules have initiated. I also noticed that the calibration function on the main screen and the 10w laser option under advanced settings are both no longer there. I’m able to send a file to the machine and start the rotary/laser calibration process (set material length/diameter, lower laser). However, when the laser and rotary start running the job, the laser is far out of focus and no options are available for adjusting it before or during a job.

I’ve tried with two different controllers just to see if it was related to that, but both behave the same way.

Any thoughts or suggestions?

With the rotary/10W, the calibration is handled when you run the file. It’s kind of nice, but it does make doing multiples of the same project cumbersome.