Temperature while paused

Hi. As I have A250 in my room, I need to pause prints during night. But I noticed that while paused I cannot change temperature of nozzle and bed. Is there reason for that? Or can I do it somehow?
Thanks.

Try to run a Filament change?
Over night I would try power loss recovery :+1:

Yeah, but pulling cable out is not good solution long term.
Also while paused I can change only temperature of nozzle, bed, Z-offset and work speed

I am not sure, what are you asking for?
Give the power supply a power outlet with switch and go for it.
In the first post you said, you can’t adjust the nozzle temp and in your second post you wrote you can do it. - I am not sure now if it is, but you surely can do it when you run into filament change…

Sorry, lost in translation.
When paused, i can go to setting and have ability to change temperature of nozzle, bed, Z-offset and work speed. But when I do so it does nothing. I changed temp from 200 to 0, but nozzle was still heating itself.
Shutting whole SM2.0 is possibility, but it seems to me that’s not really good practice. Why can’t I have ability to pause and resume without turning it down?

I thought about the fan noise.
I have tried, this is a firmware bug @parachvte.
If the printer is in pause mode, you could adjust the temperature of bed and nozzle, the new setpoint will be displayed but not heated to there.

Alternatively, as workaround, it is possible to give the controller the new temp.-setpoints via USB and terminal. This definitely works :slight_smile:

M104 S200; Hotend Temp.
M140 S50; Heated Bed Temp.

Unfortunatelly wlan doesn´t work, but this is because of the hanging touchscreen, i guess.
Hope this helps!

I have found switching the power supply off during a print is the same as unplugging it but is probably a little safer… I don’t recommend cooling the bed in the middle of a print, it can cause bed adhesion and warping issues because of thermal stresses. If you find the machine is too loud maybe place it in an enclosure with sound insulation, Or inside a closet.

This is the expected behavior on current firmware versions, commands for adjusting temperatures and normal G-code commands are sent to be executed separately.

Commands that adjusting temperatures are only considered to be executed when in printing state (and not when paused). But you are right, we should be able to turn off the temperatures (and fans) when in paused state.

can we also have the “stop print” command override the temp wait command? its annoying when you accidentally select the wrong print and have to wait for the bed to heat up before it will cancel the print.