Snapmaker Luban v4.4.0 is Released

There are a lot of macOS issues with Luban (past and present). My #1 peeve is none of the dialog buttons respect the keyboard (ESC - cancel, ENTER - OK).

Also, I have a 21:9 monitor, and the sidebars in Luban aren’t resizable. A lot of the text is truncated “HATCHBO…” because the extremely narrow fields. Why pad the popup with dead space?

Basic UI things like that are inexcusable.


1 Like

Can you give us a screenshot to understand the situation?

Can you export the log on the screen after trying to connect the machine with Luban? This will help us identify the problem

I changed the wall count after the screen but like the sreen shows it in the tails the inner walls doesn’t go all the height

and the infill isn’t shown

tried on another model and I saw the infill (both has error and has been repaired with luban)
think I will print it in resin so

Looks good, but it’s still the least intuitive software I’ve used on a Mac. Worked on it all morning and things were just a mess. YouTube tutorials are now out of date after the interface change. Got nothing done. Still can’t set the machine to local time zone… exhausting.

I’m having significant issues with the new luban software release. The camera capture function has stopped working. When it takes the picture it doesn’t allow me to move back to the edit view and it moves my design halfway across the screen.

When I went to laser engrave something the device smashed the laser against the plate.

Something is seriously wrong. Now the device keeps trying to laser everything (no matter where the design is on the grid) on the bottom left hand corner off of the laser bed. Is there any way to go back to the prior version of the software?

Just re-install 4.3.2 is ok. By the way, when u go to laser engrave, which mode did you choose or attach the mode selection popup image before engraving? We tried to fix this issue. Due to the path of some people, we could not reproduce it. Try this package

Is there any more info on the “Model Repair” feature?
I loaded an STL and got an error and recommendation to Repair… but what was wrong? What was changed or fixed? Is there a way to see what REPAIR actually does to a 3D model?
It sounds like a cool feature

This breaks my connection. Ive gone baxk to 4.2.2 and it works flawlessly. No drop outs what so ever.

Snapmaker Original & 4.4.0 Update [Extremely Disappointing Experience]

The update has significantly destroyed the smooth, responsive and stable experience I once had. The print sends and Luban freezes, some 4hrs in, the entire print stops. Luban becomes virtually non-responsive where it must be forced quit.

Anyone else experiencing this?

Hey, sorry for your bad experience with the update. To help us to address the problems, we would like to learn more details. Before you update to Luban 4.4.0, which version did you use? And what do you mean by “print sends” here? For the Snapmaker Original, there is no wifi connection between Luban and machine. So, you need to connect Luban to the machine with a cable, then the instruction should be “Start print”.

In the next UI update (I pray it’s as soon as possible). Please combine this version and the previous version for 3D printing at least. This version for 3D printing is horrible in my opinion. Yes all the options are nice, however, there is no clear divisive profile to be made. Luban once being easy to use is now just a pain logistically within the software.

I just updated to the latest A250 firmware and Luban v4.4.0 and I have to say it is a huge step backwards. All my custom settings vanished, a lot of work down the drain. My A250 is no longer visible in Luban via wifi, although it worked fine before the update. And yes, the A250 is connected. I can get to it if I track down the physical IP addr and use that. The ‘model has errors’ and correction is total garbage. Complains about everything and if I let it fix an stl, the resulting print is full of serious print errors. If I tell it to NOT fix, same stl prints perfectly. Finally, the UI is now horrible. I don’t want that silly simplistic setting panel, I want to easily be able to set custom params INCLUDING head temp, bed temp, fan, etc. like I could in the previous release. I really get annoyed when a company takes a perfectly good UI and feels they have to ‘improve’, not.

Me too. Seems to be a common problem. Anyone know of a workaround? Otherwise prog seems OK?

I’ve also tried restarting and rebooting everything. But still get other “connected to other device” issue. I’ve got no other devices on.!

I’ve experienced the freeze as well. When I try to generate the g-code, it will just sit there for hours before it will finish loading. I just use a different slicer now because I can’t deal with the wait.

I am having travel issues while printing pier like structures.
Not sure what setting is causing the circled travel to occur…