Snapmaker 2.0 magic number?

The magic number for the SM2 is 0.04mm so why are the TS and Luban set for movements that are not a multiple of the 0.04mm magic number? This may be part of the issue with backlash and inconsistency in the bed leveling routines.

Justification for the magic number:

Stepper is 1.8° per full step

Leadscrews in the motion modules are 2mm pitch 8mm lead (4 start)

Firmware is set to 400 steps per mm and 1/16 microstepping (limit of the Toshiba stepper drivers used in the motion modules and also limit of the A4988 used in the extruder module) (also explains why the machine is so loud)


Someone else had told me that it was 0.03mm minimum travel.

@Edwin What do you think about that ?
Check this video from a Prusa and this how the Z offset skip value (lower the speed view on Youtube)

1 Like

I will keep my eyes on this post.

I have a Prusa Mk3S and the Mini and they both run 7x7 mesh grids. They also respond near instantaneously to the live Z adjustment. I have never had a bad first layer when the Z is adjusted correctly.

Is there a way we can fix this in our settings? or do we have to wait for a firmware release?

I think the problem persist aslong the bed is as it is - its not possible to groundlevel the bed.
The most printers i know can level the bed with 4 screws to bring it even at the 4 corners. From there the autolevelprocess can work properly. There is defently to do some work.