Snapmaker 2.0 Crashed into bed while auto-levelling, doesnt move now

Im using a A250, I last used it a few months back. Today I while auto calibrating it crashed into the bed. After which I got a prompt to download the latest firmware. And once it booted up, I tried manual calibration. It crashed into the bed again and the 2nd point was off the print bed (towards the left).

Now the printer doesnt home or move. I attached a video below.
Im not sure if the rails are damaged because it crashed into the bed or if the rails are out of sync because it collided with something.

The last firmware I had on my thumbdrive is V1.10.0. I just overwrote the latest V1.12.0 with V1.10.1 firmware, I can move the head along the z axis but not the X Axis. The bed moves along the Y axis just fine.

I attached a video of the homing position and manual calibration… https://photos.app.goo.gl/Gfbjb5BGEGwY5iGh9
https://photos.app.goo.gl/6rDAJEzdbyLX85Re9

I wonder if maybe your rails are just too out of sync, have you tried moving the bed all the way forward while the power is off?

Not too sure how I can fix out of sync rails. I haven’t tried moving the bed because its the X-Axis on the print head that is buggy. Im gonna try moving the X axis while its powered off now. Will update the thread

Does the X move in either direction? Moving in only one direction can indicate a stuck limit switch

It does during manual calibration. But it refuses to move in the control menu.

What happens when you home?

Isn’t the X axis moving in the opposite direction?

@Jasper

You can see that the X coordinate on the touchscreen is 0, which means that the machine cannot recognise the X axis.

It would be appreciated if you can send me the booting log of the machine.

After you connect the machine with your PC via the USB cable, you can input the command M1999 to reboot the machine and you can see the log in the console.

You can copy it and paste it here.

Then, please use the command “M2000 S0” in the console and post the return value here as well.

Looking forward to your reply.
Edwin

1 Like

Sometimes I don’t believe the X axis linear module beam is perfectly parallel to the build plate or enough. So what I do is I get a couple of believe it or not Campbell’s soup cans and that my case it’s the cream of mushroom cans and put them either side of the build plate on the base plate and turn the power off and slide the X axis linear module down to just touch the tops of the soup cans so that I know it’s perfectly parallel at least to the base.

1 Like

Hi Edwin,

Apologies for the delay. I didnt see your reply and I did not have access to my machine till today. I have uploaded the log below, only 4 LEN appears and Axis: 0 doesnt appear.

Does that mean my X-Axis has failed?

@Jasper unfortunately Edwin is no longer with Snapmaker. After reading the comments to get caught up, I’m pretty sure your X-axis has gone bad. Have you tried swapping the rails around? Swap the x rail out with another rail, if it still doesn’t see the x axis after swapping then it’s your controller.

Hi Artezio,

Do i have to dismantle the machine and swap the rails or just swap the wires connecting to the controller?

@Jasper dismantle and swap the rails, don’t swap cables around without also moving the rails, the rails need to be properly connected into the corresponding port for the current role that the rail is oriented as.

You don’t have to completely dismantle.
Just enough so that they can move independently.
You don’t want them to be trying to do opposite moves and you want to see what each one is doing by itself
-S

@Artezio Apologies for the delay. I have dismantled the X-Axis and swapped it with the Y-Axis on the right.
I am certain the X-axis has gone bad. Can you advise on my next step.

Swapping of rails-Broken Rail

Working X-Axis (previously Y-Axis)

Update: The broken rail somehow works when used for the Y-Axis. I just had a successful print.
However, the entire print area doesn’t seem to align with the print bed. (both during printing and during calibration.

yeah i would consider that broken one as ‘for spare parts’ only if i was you…